2

When I used useradd command to add a new user for my Solaris 10 System, I specify /home/user-name to be its home directory.

but the command didn't run successfully, and when I put the /export/home/user-name as its home directory it runs successfully.

The first command is: useradd -md "/home/munix" -s "/bin/ksh" munix --> give me an error, which is the home directory can not be created, but the user is added to passwd file

the second command is: useradd -md "/export/home/munix munix" munix --> home directory created successfully

why????

  • do /home/munix and /export/home/munix point to the same location? – Rory Alsop Jan 19 '13 at 9:09
  • No, they don't point to the same location – MUE Jan 19 '13 at 9:11
4

On Solaris /home is managed by the automounter by default. The simplest way if you don't need that functionality is to disable it.

Just comment out the line that reads something like /home auto_home -nobrowse in the /etc/auto_master file and then restart autofs:

svcadm restart autofs

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.