0

I have a Ubuntu 20.04 VM running on Virtual Box. I'm trying to install Splint on this VM following the instructions on the website (http://splint.org/linux.html).

Point 5 of the instructions says to run make install. When I run it I obtain an error:

$ make install
cd . && /bin/bash /home/user/Downloads/splint-3.1.1/config/missing --run aclocal-1.6 
/home/user/Downloads/splint-3.1.1/config/missing: line 46: aclocal-1.6: command not found
WARNING: `aclocal-1.6' is needed, and you do not seem to have it handy on your
         system.  You might have modified some files without having the
         proper tools for further handling them.  Check the `README' file,
         it often tells you about the needed prerequirements for installing
         this package.  You may also peek at any GNU archive site, in case
         some other package would contain this missing `aclocal-1.6' program.
make: *** [Makefile:138: aclocal.m4] Error 1

I tried to solve this problem following this answer on Stack Overflow, without success. Then I removed the VM, created a new one and restarted the installation process till point 5, so the actual VM is clean.

Any idea on how to solve the problem?

6
  • Is the automake package installed on your system? – steeldriver Nov 4 '20 at 15:48
  • @steeldriver No, should I install it? – Francesco Lucianò Nov 4 '20 at 16:48
  • I believe it should contain the requested aclocal-1.16 so yes I suggest installing it – steeldriver Nov 4 '20 at 16:53
  • @steeldriver I installed it, still the same error – Francesco Lucianò Nov 4 '20 at 16:58
  • Did you re-run ./configure after installing the package? or just jump straight to make install? – steeldriver Nov 4 '20 at 17:09
0

I finally discovered I could also use apt install splint, and this worked without problems. Probably there's something wrong with the archive they provide, I wasn't able to complete the installation process following the instructions in the official webpage.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.