0

Normally, when I have two panels (windows?) open in vim, I use c-w c-w to switch between them. This suddenly stopped working.

So one would think the problem could be with vim, with the terminal emulator, or with KDE, or some other software getting in the way.

I'm running vim-gtk3 in Debian Netrunner 20.01 which is KDE, and normally using Konsole, but also Terminator in debugging this, on a Thinkpad T410. I've posted at Netrunner forums and Vi&Vim, and it was suggested that I try here.

I’ve been doing the following frequently for the last few months:

In Konsole, I go into VIM (usually through VIFM, but that doesn't seem to matter) and start editing a document. Then I do :new to get another panel, and then :Explore and start editing a second document, switching back and forth between the documents by using c-w (Ctrl-w) twice. Last night, something happened, and now when I press c-w, the first press makes the mouse pointer visible, and the second press makes the vim cursor blink once, but it does not switch panes.

The first time this happened, I did :new, then :Explore, then navigated up, and did /gyatso (a file name) and then I mistyped maybe hitting Ctrl I think, because vim came up with a small panel near the bottom with an error maybe about jump buffer being empty - something being empty anyway. I don’t know whether this typo caused all this, but since this time, I can no longer switch between panels.

Ctrl-W does exist as a KDE shortcut to close applications, but this has not changed. It’s always like that and doesn't normally interfere.

Things I’ve tried:

  • Installed Terminator and tried in that, with the same problem, so it’s not just in Konsole
  • Renamed the ~/.vim/vimrc
  • Purged and reinstalled vim and everything starting with vim-
  • Rebooted Netrunner
  • Booted into BunsenLabs (another Debian) and in Terminator, using the same ~/.vim/vimrc from Netrunner KDE, it works fine in BunsenLabs.
  • showkey gives 29 for Ctrl and 17 for u, which I suppose is correct.
  • Ran as vim --clean
  • Renamed ~/.config/konsolerc and also ~/.config/kglobalshortcutsrc then logged out and back in
  • Created a new user on Netrunner. It vim works fine there.

I don’t recall that I did any upgrades in Synaptic, but maybe I did.

Any help or suggestions how to further troubleshoot this, or just a workaround are greatly appreciated.

0

1 Answer 1

0

This isn't one of those satisfying answers, but here it is:

Someone gave the tip to use :winc as a workaround. :h winc for more info on that. This works :-)

I then, in vim :map <C-E> :winc<Space> to shorten the number of keystrokes. That worked fine, but now <C-W> has started working again, so it is fully functional normal vim in both Konsole and Terminator. I restored all the old config files, and it still works fine. So, I still have no idea what the actual problem was.

Perhaps there’s some vim config I don’t know about. ~/.vim/vimrc is unchanged in six months.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .