I have Debian 10 with KDE. Everything was working fine and suddenly today when I tried to copy a screenshot it didn't work. When I press the printscreen key, I get the popup showing the screenshot with the "copy to clipboard" button like normal, but when I try to paste it into GIMP or another image program I get:

"There is no image data in the clipboard to paste."

I tried to "restart" the clipboard by:

  • right-click on the system tray
  • uncheck clipboard
  • click apply (clipboard goes away)
  • check clipboard
  • click apply

This had no effect.

I am able to copy & paste text using ctrl-c/ctrl-v, but the text doesn't show up in the clipboard in the system tray (The images don't show up here either).

Is there some other way I can force the clipboard to restart or some way to fix this?

update I discovered that in konsole if I highlight text and middle-click, it does NOT copy the highlighted text. So the clipboard is really messed up, but I can't figure out any way to reset it.

  • Do you have any clipboard manager? What is it?
    – Quasímodo
    Nov 3, 2020 at 19:30
  • @Quasímodo I have the built-in KDE one. I think it's called klipper.
    – raphael75
    Nov 3, 2020 at 20:01
  • I think it is a bug with Klipper, I had the same issue with Xclipboard. If you kill it, does the clipboard work correctly?
    – Quasímodo
    Nov 4, 2020 at 13:17
  • @Quasímodo What is the name of the service? I don't see "klipper" in the list. Thank you.
    – raphael75
    Nov 4, 2020 at 13:57

1 Answer 1


I just ran into the same issue. What fixed it for me is disabling KDE's Klipper:

Right click system tray -> System Tray Configuration -> Entries -> Clipboard -> Disable

(and restart)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .