1

My router has an option for sharing to all connected computer the content of an USB key I connected to it. On the configuration page of the router (http://192.168.1.1/service/samba) I have :

Group name : WORKGROUP
Service name : Box
Sharing name : PartageBox
Share folder : / (which is my USB key root)

And from here, what should I do ? I think the router is correctly configured (it says that my device is shared), but I don't know how to connect to it.

I am connected to my router wifi. I tried to connect via samba, but I get an error:

me@GLaDOS:~$ smbclient -L //192.168.1.1
protocol negotiation failed: NT_STATUS_CONNECTION_DISCONNECTED

Connection to 192.168.1.1/Box and to 192.168.1.1/PartageBox give the same error.

If needed, my router is from the french Internet provider SFR

5
  • Does adding -mSMB3 to the command help? If not, what about -mSMB2 or even -mSMB1? – roaima Nov 3 '20 at 8:05
  • The 3 possibilities result in do_connect: Connection to -mSMB3 failed (Error NT_STATUS_UNSUCCESSFUL) – sayanel Nov 3 '20 at 8:14
  • One more to try. What about --option="client min protocol = NT1" (instead of the -mSMBx) – roaima Nov 3 '20 at 8:58
  • That worked ! smbclient -L 192.168.1.1 --option="client min protocol = NT1". Now it's asking my for a password... No idea what it is, but I'll look for it – sayanel Nov 3 '20 at 10:10
  • Found it. Had to force encryption method (I think?) by adding --option="client lanman auth = yes" and --option="client ntlmv2 auth = no". Final connection is done with smbclient //192.168.1.1/PartageBox --option="client lanman auth = yes" --option="client ntlmv2 auth = no" --option="client min protocol = NT1" -U sayanel – sayanel Nov 3 '20 at 10:35
1

The problem was smb protocol version (thanks Roaima), I had to force v1 with

smbclient -L 192.168.1.1 --option="client min protocol = NT1"

Then, system prompted me for my password, so I had to add -U myUser to connect with the correct username.

After entering my password, I had this message

Server requested LANMAN password (share-level security) but 'client lanman auth = no' or 'client ntlmv2 auth = yes'
tree connect failed: NT_STATUS_ACCESS_DENIED

So I had to force the use of lanman and disable ltlmn2. The final command for listing server of this client is:

smbclient -L 192.168.1.1 --option="client lanman auth = yes" --option="client ntlmv2 auth = no" --option="client min protocol = NT1" -U sayanel

And the command for connecting to the shared folder is:

smbclient //192.168.1.1/PartageBox --option="client lanman auth = yes" --option="client ntlmv2 auth = no" --option="client min protocol = NT1" -U sayanel

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.