I'm working with small network and I want to start network explorer from a terminal. When I tried to type xdg-open network:///server it opened google chrome and did nothing. I also tried to type smb://server but it hasn't helped me. I really need to run it from terminal. Does anybody know how can I do it?

  • I don't think that xdg-open currently will mount smb automatically. bugs.freedesktop.org/show_bug.cgi?id=50401 – slm Jan 18 '13 at 18:31
  • And what about network? – user35443 Jan 18 '13 at 19:07
  • Are you literally using "network://"? I don't see that as an option. I see the term "network" used as a general term for things like smb:/// and magnet:/// etc. – slm Jan 18 '13 at 19:22
  • So what should I do? – user35443 Jan 19 '13 at 18:32
  • See my answer, I still think if you want to open a samba server you have to use smb://something. You'll need to incorporate the domain name etc. into the smb:/// command in order for it to work. LMK and I can add these details to my answer. – slm Jan 19 '13 at 19:09

I think I see what you're attempting to do. On my system (Redhat Fedora 14) using GNOME desktop I have a choice of Network in Nautilus.

            ss of nautilus network:///

It's also accessible under the Places pulldown.

                                                     ss of GNOME menu

                                                         network under places

Any of the following commands open the Network Browser for me.

% xdg-open 'Network:'
% xdg-open 'network:'

NOTE: Either of the above with any number of trailing slashes appears to work too!

% xdg-open 'Network:/'
% xdg-open 'network://'
% xdg-open 'Network:///'

Tips for mounting SMB shares

xdg-open doesn't appear to be able to mount shares that aren't mounted. For example, here's a SMB share that hasn't been explicitly mounted yet via Nautilus:

% xdg-open 'smb://MYDOM;sam@bart/sam'
gvfs-open: smb://MYDOM;sam@bart/sam/: error opening location: The specified location is not mounted

However if I manually mount it in Nautilus it then can be accessed using xdg-open:

                                                         ss of smb mounted in nautilus

% xdg-open 'smb://MYDOM;sam@bart/sam'

If you'd like to avoid the step of making the SMB mount manually you could use the GNOME applet, Gigolo, which will automatically mount any shares you specify. See this page for more info on the Gigolo website and also this video.


In discussing this with OP he's using Mint 14 (Nadia), which includes a fork of Nautilus from GNOME 2 & 3. These forks are called MATE and Nemo respectively.

There is a known issue with these forks that I mentioned to OP in this launchpad issue. Specifically, there was a patch that supposedly fixed the issue with xdg-open.

| improve this answer | |
  • It must be in system settings. I'm using LinuxMint and it not works. I've also tried to install nautilus, but it still not works. Do I need to change some config files? – user35443 Jan 20 '13 at 7:58
  • I'm using 14 nadia – user35443 Jan 20 '13 at 8:18
  • I've saved it to xdg and used patch < xdg. can't find file to patch at input line 3, so I typed path manually and the path was applied. It still opens it in browser. – user35443 Jan 20 '13 at 8:44
  • Can you put your xdg-open file somewhere such as pastebin so I can see it? pastebin.com. Post the link back here. – slm Jan 20 '13 at 8:45
  • Here it is: pastebin.com/jpp28jkX – user35443 Jan 20 '13 at 8:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.