1

I am trying to get fstab option x-gvfs-show to work as expected on my default installation of Debian/buster/amd64. I did stumble upon:

but it does not seems to be working for me.


I did experiment with a remote CIFS network drive and can go from:

enter image description here

to:

enter image description here

Simply adding in /etc/fstab the following line:

$ tail -1 /etc/fstab
//freebox_server/freebox /media/freebox cifs rw,uid=1000,gid=1000,guest,defaults,noauto,x-systemd.automount,x-systemd.mount-timeout=30,_netdev,nobrl,iocharset=utf8,vers=1.0 0 2

If now I try with a second hard drive the same trick to mount disk under /media, I can neither get the following to work:

/dev/disk/by-uuid/4c0ec08d-da8b-4ea0-9d9d-2bc5ceb1fb66 /media/backup ext4 nosuid,nodev,nofail,noatime 0 2

nor:

/dev/disk/by-uuid/4c0ec08d-da8b-4ea0-9d9d-2bc5ceb1fb66 /media/backup ext4 nosuid,nodev,nofail,noatime,x-systemd.automount,x-gvfs-show 0 2

What am I missing ? For reference:

enter image description here

1

Option 1:

Navigate to the target mount point, and bookmark it. Possibly not what you had initially in mind, but it works. Source: https://askubuntu.com/a/1036779/226614

Notes:

  1. Did you reboot your system since implementing changes?
  2. Is your drive mounted?
  3. There is a related bug. What is you Gnome version? System/kernel? Many of these issues vary from version to version, so it is best if you post more details.

Related:

  1. https://askubuntu.com/questions/1036773/nautilus-not-showing-mounted-drives-in-side-bar
  2. https://www.reddit.com/r/linux4noobs/comments/cz8mbk/how_do_i_make_nautilus_show_mounted_drives_in_the/eza6r56/
3
  • Indeed the bookmark operation is close to what I had in mind. I did all of the above (reboot dance...). Since my x-gvfs-show is listed in /etc/fstab I believe this is different from the bug you referenced.
    – malat
    Dec 27 '20 at 20:15
  • Note #3 is about mount(s) that are not listed in /etrc/fstab. Mine is listed in /etc/fstab.
    – malat
    Dec 31 '20 at 10:05
  • Did you see my updated answer ? With the screenshot ? (I followed instructions from here)
    – malat
    Dec 31 '20 at 12:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.