9

I am trying to install spotify using yay on Arch linux. But when I run yay -S spotify this happens:

john@arch-thinkpad ~> yay -S spotify
:: There are 5 providers available for spotify:
:: Repository AUR
    1) spotify 2) spotify-dev 3) spotify-legacy 4) spotify094 5) spotio

Enter a number (default=1): 1
:: Checking for conflicts...
:: Checking for inner conflicts...
[Repo:1]  libcurl-gnutls-7.73.0-1
[Aur:1]  spotify-1:1.1.42.622-2

  1 spotify                                  (Build Files Exist)
==> Packages to cleanBuild?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==>
:: Downloaded PKGBUILD (1/1): spotify
  1 spotify                                  (Build Files Exist)
==> Diffs to show?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==>
:: (1/1) Parsing SRCINFO: spotify

:: PGP keys need importing:
 -> --some-key--, required by: spotify
==> Import? [Y/n] y
:: Importing keys with gpg...
gpg: keyserver receive failed: No name
problem importing keys

How can I fix this error to install package successfully ?

1 Answer 1

12

It was solved by manually adding gpg key by this command:

gpg --keyserver keyserver.ubuntu.com --recv-key <key name>

and running installation again:

yay -S spotify

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .