1

when I open ranger in the terminal as: ranger, everything is Ok. However, when I open it for example as: alacritty -e ranger the strange situation happens (1st figure). for fixing it i have to decrease the size of terminal font (2nd figure). this situation doesn't happen in urxvt and st but happens in gnome-terminal, xfce-terminal, and alacritty. my wm is i3 but to check I also tried it on vanilla xmonad but I didn't had this problem. wonder if the problem is i3 or ranger or those terminals.

btw I don't know what this situation is called.

Os: debian buster/sid (I had this issue in archlinux too)

window manager: i3

ranger with my default terminal size

ranger with small font size

5
  • I'm using alacritty on arch with i3 but I can't reproduce your problem. Try to check your TERM in ranger (:shell -w echo $TERM)
    – laktak
    Oct 30, 2020 at 23:07
  • it gives me: xterm-256color
    – ali b
    Oct 30, 2020 at 23:22
  • also in my alacritty config I have a section env: which under it, I've set TERM: xterm-256color. when I comment it, and do :shell -w echo $TERM, it gives me alacritty and it (unsetting the variable) didn't solve the problem.
    – ali b
    Oct 30, 2020 at 23:36
  • I just solved similar-looking problems by using alacritty -e env COLUMNS= LINES= ranger. I learned that trick from github.com/alacritty/alacritty/issues/…
    – Vej Kse
    Jan 27, 2021 at 22:13
  • Currently I switched to artixlinux and I don't have this problem there. If this trick solved this issue for you, please write an answer. thanks!
    – ali b
    Jan 28, 2021 at 1:50

1 Answer 1

0

Adding these lines to config.fish solved the issue for me.

set --unexport COLUMNS
set --unexport LINES

Credit for workaround goes to @faho

2
  • Welcome to the site, and thank you for your contribution. Perhaps you could add some explanation how this works to solve the OPs problem.
    – AdminBee
    Feb 11, 2021 at 8:25
  • Thanks for your attention to this nameless problem. please fell free to edit the title and question. The title is not helpful I guess and I have no idea what to write instead.
    – ali b
    Feb 11, 2021 at 18:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .