0

I am using Arch linux with i3wm on my Lenovo x390 YOGA. I also have two external monitors. I connect them throw my docking station and configure with Arandr. Screens woks fine.

But every time I connect to external monitors my cursor triples it's sensitivity on horizontal axis. My laptop's touch screen divides in to thirds and maps monitors on each.

There is output of xinput --list:

⎡ Virtual core pointer                            id=2  [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                  id=4  [slave  pointer  (2)]
⎜   ↳ Wacom Pen and multitouch sensor Finger      id=12 [slave  pointer  (2)]
⎜   ↳ Wacom Pen and multitouch sensor Pen stylus  id=13 [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                  id=17 [slave  pointer  (2)]
⎜   ↳ TPPS/2 Elan TrackPoint                      id=18 [slave  pointer  (2)]
⎜   ↳ Wacom Pen and multitouch sensor Pen eraser  id=22 [slave  pointer  (2)]
⎜   ↳ DP-2                                        id=9  [slave  pointer  (2)]
⎜   ↳ Generic ThinkPad Dock USB Audio Control     id=20 [slave  pointer  (2)]
⎣ Virtual core keyboard                           id=3  [master keyboard (2)]
    ↳ Virtual core XTEST keyboard                 id=5  [slave  keyboard (3)]
    ↳ Power Button                                id=6  [slave  keyboard (3)]
    ↳ Video Bus                                   id=7  [slave  keyboard (3)]
    ↳ Sleep Button                                id=8  [slave  keyboard (3)]
    ↳ Integrated Camera: Integrated C             id=14 [slave  keyboard (3)]
    ↳ Integrated Camera: Integrated I             id=15 [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard                id=16 [slave  keyboard (3)]
    ↳ ThinkPad Extra Buttons                      id=19 [slave  keyboard (3)]
    ↳ DP-2                                        id=10 [slave  keyboard (3)]
    ↳ Generic ThinkPad Dock USB Audio             id=11 [slave  keyboard (3)]
    ↳ Generic ThinkPad Dock USB Audio Control     id=21 [slave  keyboard (3)]

This making the touch screen nearly unusable. How can I disable this function ?

Thank you for help

PS: If you need any more information, ask in comments and I will provide it.

0

The solution is to add this code to your ~/.config/i3/config:

# Map input devices only to embedded screen
exec --no-startup-id xinput --map-to-output 13 eDP1     #Wacom finger
exec --no-startup-id xinput --map-to-output 12 eDP1     #Wacom pen
exec --no-startup-id xinput --map-to-output 22 eDP1     #Wacom pen eraser
exec --no-startup-id xinput --map-to-output 17 eDP1     #Touchpad
exec --no-startup-id xinput --map-to-output 18 eDP1     #Trackpoint

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.