I have been trying to get firefox to work with only X server. For the most part, things have run smoothly, until right now, at the end, I face two seemingly insurmountable obstacles:

  1. The dropdown menus in firefox do not stay open. It's like they flicker for a second and then disappear. I can't help but wonder if there is a "focus" issue?

  2. Firefox refuses to pull in my profile information. I moved my profile from an Arch distribution, which should have worked as it was moved from yet another distribution without issue. But now, even with manually telling it to use my profile, it still doesn't do so.

For general information, I am working on a gentoo system without window manager. My goal here is to have nothing but an X server that runs firefox. I will not run any other GUI applications out of it. Everything else will be console, so I don't want a window manager or anything.

Can anyone help please? If you need any additional information from me, just ask. I was unsure what would be helpful, but can get you what you need if you have the time to help.

  • 1. Not idea what might be wrong 2. Firefox profiles are interchangeable not just between Linux'es but between Windows and Linux as well - I've copied them both ways many times and everything just worked. Check the contents of /home/$username/.mozilla/firefox/profiles.ini and make sure everything is correct in it. Oct 29, 2020 at 22:17
  • Your two problems are unrelated. As to the first, firefox does not work without a window manager. It won't even work with a wm which sticks to the icccm and ewhm standards, because it makes assumptions about a click to focus interface, and any wm should have special quirks for it. That being said, a very minimal window manager could do -- provided that you give up on the idea of running it without a window manager.
    – user313992
    Oct 29, 2020 at 23:43
  • Firefox also needs a session manager (or special accomodations for it to be closed before the Xorg server, or the browser.sessionstore.resume_from_crash=false in about:config).
    – user313992
    Oct 29, 2020 at 23:45
  • @user414777 Can you elaborate please? I've seen people say that a window manager is not necessary, and others, like yourself, saying it is. I've gotten firefox running, and am in fact using it to reply to you right now. The only issue is the menu thing (and the profile thing which, as you mentioned, is probably unrelated). Are you saying this is the sole problem firefox has running without a window manager? Or are there others? Thanks for the help!
    – gidgers
    Oct 30, 2020 at 11:16
  • No, the menu is not the only problem. The drop down list will not work when you start typing in the address box. Other dropdown lists may not work. Input boxes sometimes fail to focus. When the root window is resized, Firefox has no way of knowing it to folllow by resizing its own top or full-screen window. And many many other bug-like things, that will never be fixed, because Firefox is not designed to work without a wm. But there are also some conceptual problems: what should happen when the user creates a new window with Control-N?
    – user313992
    Oct 30, 2020 at 16:03

2 Answers 2


I have this exact same system.

I put exec firefox in ~/.xinitrc.

Firefox flickered the menus for a while, but then the right click menus and the rest fell into place magically after opening a Google meet. I don't know what happened, but so far having a good time. Firefox has a built-in file browser and can play videos and view pdfs, images and all that, so right now it's a complete operating system in and of itself.

To answer your question, try a reboot and startx again and see whether the problem fixes itself. It worked for me. I'm using arch so maybe it's something to do with openrc on Gentoo?


The menus disappearing is an issue with the focus, yes. X.org automatically focuses the window that the mouse cursor is on when no window manager runs. When it tries to focus the menu window (because Firefox opens it in a window or window-like thing) the main Firefox window loses focus and thus closes the menu.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .