0

I setup a secured VNC link to my Ubuntu 18.04 office computer from home.

I'm using unity to work when in the office but installed XFCE on it for access over ssh. I can connect fine over VNC and am presented with the XFCE desktop but when i start an application (Terminal let's say), it won't appear on the screen. And when I check on the office computer, the application did get launched but showed up on the secondary physical screen in the office instead. Now, I'm not sure how I can make the application show on the same screen that I run VNC on, any hints? My xstartup just looks like:

$ cat /home/ron/.vnc/xstartup
#!/bin/bash
xrdb $HOME/.Xresources
startxfce4 &

I tried to start the server with $ vncserver -geometry 1280x1024 -Monitor 1 and $ vncserver -geometry 1280x1024 -Monitor 0 but that did not change anything (also, the geometry doesn't look like it got accepted either) and the logfile says Unrecognized option: -Monitor (I found it on https://help.realvnc.com/hc/en-us/articles/360002251297#server-monitor)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.