7

I've just installed Fedora 18, and trying to configure sshd - I used chkconfig but this is only starting sshd when a user is logged in. How do I change so that sshd starts on system boot?

  • @Christopher yes, thanks. Want to add this as answer? – David John Smith Jan 18 '13 at 2:44
  • 1
    chkconfig should be forwarded to systemctl and just work. What do you mean by "only starting when a user is logged in"? – mattdm Jan 18 '13 at 15:39
  • @mattdm I mean that I was not able to ssh in to the machine until the user had logged in. I thought it was to do with run level, however I'm a noob and could be mistaken – David John Smith Jan 19 '13 at 2:48
  • 1
    @David That's very strange.... Oh! Was the network user controlled? It's possible that the net was only up when someone was logged in. – mattdm Jan 19 '13 at 3:24
11

Try the Fedora 17 method...

systemctl enable sshd.service

This will enable sshd so it starts on the next boot and every subsequent boot, but it won't immediately start up sshd.

At this point you can either reboot (which will start it up) or start it manually using

systemctl start sshd.service
1

I had the same issue in Fedora 21, I finally zeroed out the Listening Address,ListenAddress 0.0.0.0 and now when they system reboots I am able to SSH without logging into the system first.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.