0

I get this every time I run terminal on kali linux. It started happening when i added the alias "wifi". This is the error i get

bash: source: filename argument required
source: usage: source filename [arguments]
bash: /home/tom/.bashrc: Permission denied
bash: source: filename argument required
source: usage: source filename [arguments]
bash: /home/tom/.bashrc: Permission denied

This is my bashrc file:

# ~/.bashrc: executed by bash(1) for non-login shells.
# see /usr/share/doc/bash/examples/startup-files (in the package bash-doc)
# for examples

# If not running interactively, don't do anything
case $- in
    *i*) ;;
      *) return;;
esac

# don't put duplicate lines or lines starting with space in the history.
# See bash(1) for more options
HISTCONTROL=ignoreboth

# append to the history file, don't overwrite it
shopt -s histappend

# for setting history length see HISTSIZE and HISTFILESIZE in bash(1)
HISTSIZE=1000
HISTFILESIZE=2000

# check the window size after each command and, if necessary,
# update the values of LINES and COLUMNS.
shopt -s checkwinsize

# If set, the pattern "**" used in a pathname expansion context will
# match all files and zero or more directories and subdirectories.
#shopt -s globstar

# make less more friendly for non-text input files, see lesspipe(1)
#[ -x /usr/bin/lesspipe ] && eval "$(SHELL=/bin/sh lesspipe)"

# set variable identifying the chroot you work in (used in the prompt below)
if [ -z "${debian_chroot:-}" ] && [ -r /etc/debian_chroot ]; then
    debian_chroot=$(cat /etc/debian_chroot)
fi

# set a fancy prompt (non-color, unless we know we "want" color)
case "$TERM" in
    xterm-color|*-256color) color_prompt=yes;;
esac

# uncomment for a colored prompt, if the terminal has the capability; turned
# off by default to not distract the user: the focus in a terminal window
# should be on the output of commands, not on the prompt
force_color_prompt=yes

if [ -n "$force_color_prompt" ]; then
    if [ -x /usr/bin/tput ] && tput setaf 1 >&/dev/null; then
    # We have color support; assume it's compliant with Ecma-48
    # (ISO/IEC-6429). (Lack of such support is extremely rare, and such
    # a case would tend to support setf rather than setaf.)
    color_prompt=yes
    else
    color_prompt=
    fi
fi

if [ "$color_prompt" = yes ]; then
    prompt_color='\[\033[1;34m\]'
    path_color='\[\033[1;32m\]'
    if [ "$EUID" -eq 0 ]; then # Change prompt colors for root user
    prompt_color='\[\033[1;31m\]'
    path_color='\[\033[1;34m\]'
    fi
    PS1='${debian_chroot:+($debian_chroot)}'$prompt_color'\u@\h\[\033[00m\]:'$path_color'\w\[\033[00m\]\$ '
    unset prompt_color path_color
else
    PS1='${debian_chroot:+($debian_chroot)}\u@\h:\w\$ '
fi
unset color_prompt force_color_prompt

# If this is an xterm set the title to user@host:dir
case "$TERM" in
xterm*|rxvt*)
    PS1="\[\e]0;${debian_chroot:+($debian_chroot)}\u@\h: \w\a\]$PS1"
    ;;
*)
    ;;
esac

# enable color support of ls, less and man, and also add handy aliases
if [ -x /usr/bin/dircolors ]; then
    test -r ~/.dircolors && eval "$(dircolors -b ~/.dircolors)" || eval "$(dircolors -b)"
    alias ls='ls --color=auto'
    #alias dir='dir --color=auto'
    #alias vdir='vdir --color=auto'

    alias grep='grep --color=auto'
    alias fgrep='fgrep --color=auto'
    alias egrep='egrep --color=auto'
    alias diff='diff --color=auto'
    alias ip='ip --color=auto'

    export LESS_TERMCAP_mb=$'\E[1;31m'     # begin blink
    export LESS_TERMCAP_md=$'\E[1;36m'     # begin bold
    export LESS_TERMCAP_me=$'\E[0m'        # reset bold/blink
    export LESS_TERMCAP_so=$'\E[01;33m'    # begin reverse video
    export LESS_TERMCAP_se=$'\E[0m'        # reset reverse video
    export LESS_TERMCAP_us=$'\E[1;32m'     # begin underline
    export LESS_TERMCAP_ue=$'\E[0m'        # reset underline
fi

# colored GCC warnings and errors
#export GCC_COLORS='error=01;31:warning=01;35:note=01;36:caret=01;32:locus=01:quote=01'

# some more ls aliases
alias ll='ls -l'
alias la='ls -A'
alias l='ls -CF'

# Alias definitions.
# You may want to put all your additions into a separate file like
# ~/.bash_aliases, instead of adding them here directly.
# See /usr/share/doc/bash-doc/examples in the bash-doc package.

if [ -f ~/.bash_aliases ]; then
    . ~/.bash_aliases
fi

# enable programmable completion features (you don't need to enable
# this, if it's already enabled in /etc/bash.bashrc and /etc/profile
# sources /etc/bash.bashrc).
if ! shopt -oq posix; then
  if [ -f /usr/share/bash-completion/bash_completion ]; then
    . /usr/share/bash-completion/bash_completion
  elif [ -f /etc/bash_completion ]; then
    . /etc/bash_completion
  fi
fi
alias wifi='sudo airmon-ng stop wlan0mon ; sudo service network-manager restart'
source
/home/tom/.bashrc
source
/home/tom/.bashrc

I'm very new to linux in general, so any help is appreciated. Thanks!

1 Answer 1

3

At the bottom of your ~/.bashrc you have:

alias wifi='sudo airmon-ng stop wlan0mon ; sudo service network-manager restart'
source
/home/tom/.bashrc
source
/home/tom/.bashrc

Change this to

alias wifi='sudo airmon-ng stop wlan0mon ; sudo service network-manager restart'
source /home/tom/.bashrc
source /home/tom/.bashrc

You might want to consider deleting the duplicate line, or maybe even just copying the contents of /home/tom/.bashrc to ~/.bashrc because if Tom choses to revoke your read-permissions to his home-directory, you'll have problems again. If you are Tom, you might want to delete those lines as a recursive .bashrc might cause a hangup.

Edit: You are tom! The source lines will cause a hangup (infinite recursion). Delete those lines so that you simply have this at the end:

alias wifi='sudo airmon-ng stop wlan0mon ; sudo service network-manager restart'
4
  • 2
    Also, if your account is tom then you'll have a loop.
    – jsbillings
    Commented Oct 28, 2020 at 13:55
  • I did that (I am tom) but now when i open terminal, it is blank (no tom@kalitom -$) and i can't run any commands... Any help? I replaced what you said with alias wifi='sudo airmon-ng stop wlan0mon ; sudo service network-manager restart' source /home/tom/.bashrc I didn't use the second line twice like you said
    – Tf0R24
    Commented Oct 28, 2020 at 14:11
  • @Tf0R24 unfortunately if /home/tom/.bashrc is the same as ~/.bashrc then you are recursively sourcing the file from itself. You will need to use a non-shell based text editor or start a non-bash shell (such as /bin/sh) or invoke bash with -norc, so that you can edit the file again and remove the source line. Commented Oct 28, 2020 at 14:22
  • This worked. Thanks so much!
    – Tf0R24
    Commented Oct 28, 2020 at 14:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .