1

I'm using X1C gen 7 4k, xfce, lightdm, uefi & grub install

Arch wiki wrote:

Gimp 2.10 To fix toolbar icon sizes, update Preferences->Interface->Icon Theme->Custom icon size to huge or other value. If menu fonts are still too small you can update an existing theme by copying it from /usr/share/gimp/2.0/themes into ~/.config/GIMP/2.10/themes/ and changing gtk-font-name and font_name in gtkrc into something bigger like Sans 30. Then select the new theme from Preferences > Interface > Theme. When copying make sure to rename the new directory into something different from the original name (example Dark > DarkHighDPI). You can also try using gimp-hidpi (installation instructions are outdated and refer to version 2.8, in Gimp 2.10 the theme should be installed into ~/.config/GIMP/2.10/themes/)

I've done all the above to no avail, nothing changed. I'm not sure where to go from here.

What I did exactly was:

  1. changed the settings in preferences and made the icon size huge.

    1. mkdir ~/.config/GIMP/2.10/themes/DarkHighDPI
  2. from within

    /usr/share/gimp/2.0/themes/Dark

I

sudo cp -r gtkrc ui ~/.config/GIMP/2.10/themes/DarkHighDPI
  1. I edited the gtkrc file with sans 30 for both the gtk-font-name and font_name

  2. Then from within the gimp program again I changed the theme settings to DarkHighDPI

  3. rebooted my laptop started gimp, still no change.

  4. I restored a timeshift backup to revert all changes I had made.

2 Answers 2

1

Tested with GIMP 2.8.22 on Ubuntu 18.04 (XFCE), so I don't know if this works with your version on Arch.

  1. Copy the default theme to ~/.gimp-2.8/themes/HiDPI:

    mkdir -p ~/.gimp-2.8/themes
    cp -a /usr/share/gimp/2.0/themes/Default ~/.gimp-2.8/themes/HiDPI
    
  2. Edit ~/.gimp-2.8/themes/HiDPI/gtkrc and add a line font_name = "sans 30" (copied and adjusted from the "Small" theme):

    ...
      stock["gtk-dialog-warning"] =
        {
          { "images/stock-warning-64.png", *, *, "gtk-dialog" }
        }
    
      ### this line was added ###
      font_name = "sans 30"
    
      GtkPaned::handle-size             = 6
      GimpDockWindow::default-height    = 300
      GimpDock::font-scale              = 0.8333
      GimpMenuDock::minimal-width       = 200
    ...
    
  3. Open GIMP, go to Edit -> Preferences -> Theme and select theme HiDPI.

    Result: GIMP menu Sans 30

5
  • 1
    On the arch wiki it says [quote=wiki]You can also try using gimp-hidpi (installation instructions are outdated and refer to version 2.8, in Gimp 2.10 the theme should be installed into ~/.config/GIMP/2.10/themes/)[/quote] Commented Oct 27, 2020 at 21:23
  • So I'm pretty sure it won't work for me. I will try again tomorrow using the mkdir cmd with the -p flag and the cp with the -a flag. lol i'm very new to linux I don't really know/understand those flags yet. I think the -p flag makes parent directories, but I don't know what that means.Thank you for your reply. Commented Oct 27, 2020 at 21:32
  • Yep, haven't tried gimp-hidpi. And my theme wasn't detected in ~/.config/GIMP/2.10/themes/, I guess it was the wrong config directory for my GIMP version since my ~/.gimp-2.8 contains lots of files and directories. Use ~/.config/GIMP/2.10/themes/ instead if that works for you. The -p flag creates both directories ~/.gimp-2.8 and ~/.gimp-2.8/themes if they don't already exist and cp -a copies recursively preserving attributes and links (archive mode).
    – Freddy
    Commented Oct 27, 2020 at 22:06
  • Thanks about the flags. thats the issue it doesn't seem to be working for me. I did think that cp -r was to copy recursively though Commented Oct 27, 2020 at 22:15
  • I could be doing it wrong, not sure. I did it the way I mentioned in my post. I didn't know how to copy the whole directory and change the name at the other end. Thats why I made the directory first and then went into the default theme directory and copied from there Commented Oct 27, 2020 at 22:16
1

I apologise for wasting your time. The correct way of doing it is what I did in the beginning but.....when editing the sans 30 the line has to be uncommented.

bad error on my part.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .