1

I just tried to resurrect an old MacBook by installing Xubuntu on it. However, I face a severe problem. Every time I start Xubuntu the num lock is on and there is no key on the MacBook to deactivate it. I have no idea why num lock is on at start. The keyboard works fine on Mac OS X. And sometimes after suspend on Xubuntu, the num lock gets deactivated for no apparent reason and I can use the machine until the next restart. Is there a way to disable num lock or so to solve the problem?

I have already tried to update the system to the latest version.

Edit: This question is particularly about Xubuntu. And the answer to the suggested duplicate differs from the selected answer.

3
  • 3
    try setleds command – Ipor Sircer Oct 27 '20 at 6:50
  • Thanks for the comment. Unfortunately, setleds produces an error: setleds: Error reading current flag setting. Maybe you are not on the console?: ioctl KDGKBLED: Inappropriate ioctl for device. – Daniel Oct 27 '20 at 11:05
  • Maybe I wasn't explicit enough? The suggested duplicate is different since it does not concern Xubuntu in particular and does not work on Xubuntu. At least on vanilla Xubuntu. – Daniel Nov 19 '20 at 9:12
1

Using numlockx to disable on each session start worked for me. Add it on Xfce Settings / Session and Startup / Application Autostart

numlockx off

Since it's Xubuntu and I have it booting to X, I can switch to terminals once this is fixed.

My system: MacBook4,1 1.0 - Intel Core 2 Duo T 8300 @ 2.4GHz - Intel 965GM - Ubuntu 18.04.5 LTS x86_64

1
  • Perfect! Works now. I must say, that the keyboard wasn't usable by default was a bummer. Strange that this hasn't been fixed yet. – Daniel Oct 31 '20 at 9:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.