-1

As the title suggests, everytime I try to boot into Kali Linux with 5.8.0 Kernel I get stuck at the loading screen (the dragon) kali stuck However, using the 5.7.0 Kernel seems to be no problem. At first I thought it was because of xfce and reinstalled it with gnome (which wasn't the problem) I tried editing the grub parameters for linux. Setting nomodeset instead of quiet splash resulted in another screen, where I wasn't stuck, but I could not do anything. And leaving quiet nomodeset results in a kernel panic.

I also once tried exporting Kali Linux from my Laptop and then imported in on my PC --> same errors.

Googling all kinds of combinations didn't get me anywhere. I don't know what to do anymore, but I need Kali for school.

My Host has an AMD Ryzen 5 2600 (--> maybe this is the cause) The VM: 4 Cores, 4000MB RAM

3
  • If you can get a recovery prompt, then I suggest update-initramfs -u. As far as I understand, it reconfigures your kernel to work with your hardware. This has saved me lots of times when moving a virtual machine to bare-metal, or moving a hard-drive to a different motherboard.
    – Stewart
    Oct 26 '20 at 20:47
  • 1
    If there is no specific reason to choose Kali, I would suggest to use a more common distribution, e.g. Ubuntu. If your teacher requires you to use Kali, he/she should also provide support if you have problems.
    – Bodo
    Oct 26 '20 at 22:04
  • @Stewart did not help, but still thanks
    – 0Adiber
    Oct 27 '20 at 23:20
0

I sort-of fixed this issue, but going into advanced option, and selecting kernel 5.7.0. Then use this thread: Set Default Kernel to set as the default kernel. I have come to the assumption that 5.8.0 is buggy. Use 5.7.0 instead - that's what I'm now using.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.