1

QEMU newbie here. I am trying to boot a VM using QEMU, for increased performance I am trying to use a virtio-scsi mounted drive. I am following the steps given here. However when I boot my VM and I try to check for the virtio-scsi queues using ls /sys/block/sdb/mq/ I do not see the option of mq, does that mean I was unable to mount a virtio-scsi drive? But when I checked my boot up logs I could see I was able to mount my drive.

This is the command I am using to boot my VM

sudo qemu-system-x86_64 -hda x86.img -m 8096 -serial mon:stdio -nographic -smp 4
 --enable-kvm -device virtio-scsi-pci,id=scsi0,num_queues=4 
 -device scsi-hd,drive=drive0,bus=scsi0.0,channel=0,scsi-id=0,lun=0 -drive file=test.img,if=none,id=drive0

Any help would be appreciated.

1 Answer 1

0

Hopes this helps anyone facing the same issue, there is a config which has to be enabled while compiling the guest kernel -

CONFIG_SCSI_MQ_DEFAULT=y

You can then use ls /sys/block/sdq/mq/ to see the number of multi queues.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .