1

I sort of have a specific problem.

I am new to dual booting, this being my second time.

I accidentally installed and upgrade to my manjaro kernel which had rt at the end, which caused a lot of errors to me, one of the first making the efivarfs filesystem unmountable, and this is - I believe - another problem from that.

Some days after rebooting my laptop, it couldn't identify any bootable device nor partition, which was a very weird problem that I fixed by using chroot on my manjaro bootable usb, and installing grub.

I straight after that updated my kernel to a non-rt version which stopped the first problem, but isn't fixing the second: I am unable to boot into Windows from grub.

Both are UEFI. (Well, I think so. I don't think I checked Windows, but I did check Manjaro), one of the ways I tried to solve this being going into the grub commandline and trying to boot into windows using the bootmgfw.efi file in /Windows/Boot/EFI/. Which results with a screen in windows saying something about windows failing to start because of a recent hardware change.

It tells me to reinstall it, but I do not wish to lose the data and I do not have my live installation media for windows,thus it is not an option.

So, I try to use the bootmgr.efi file because it is the boot manager, but grub says it cannot load the image, even after trying grub-update.

(If you couldn't tell, most of the things I did were off reading other answers and questions online).

3
  • Grub only boots working Windows. If UEFI install, directly boot from UEFI boot menu. Windows probably did an update & turned fast start up back on. askubuntu.com/questions/843153/… & askubuntu.com/questions/145902/… If BIOS, you have to temporarily install a Windows boot loader, fix Windows & then restore grub.
    – oldfred
    Oct 26 '20 at 13:10
  • I'm unable to boot windows from the UEFI boot menu, I assume I access it by pressing F12 while the laptop is starting up, if so, I already tried that and it boots me straight to manjaro. I am pretty sure my system is UEFI, but it looks like it isnt according to what you said, so how do I install the windows boot loader?
    – Mon
    Oct 26 '20 at 13:15
  • Best to use your Windows repair flash drive, but must boot it in correct mode UEFI or BIOS. If Windows can be seen, you can use Boot-Repair. But you must know if UEFI or BIOS and boot live installer in that mode and then add Boot-Repair using ppa. Lets see details, use ppa version with your live installer (2nd option) or any working install, not Boot-Repair ISO: Please copy & paste the pastebin link to the Boot-info summary report ( do not post report), do not run the auto fix till reviewed. help.ubuntu.com/community/Boot-Repair & sourceforge.net/p/boot-repair/home/Home
    – oldfred
    Oct 26 '20 at 13:19
0

Just passing through . . . but I do have some experience with multi-booting in a Mac environment, and now in Sys76 laptop . . . . Basically until you have added "windows" or in my case, "OSX" possibly the UUID location into grub, grub will show the OSX partitions but it won't boot them. And, in return, any OSX upgrades will wipe all grub connections to linux . . . .

So, I use grub only to launch linux apps and I use the OSX boot manager to boot to OSX, i.e., keep them "separate" . . . . So, in your case if you try the keystroke that takes you to the BIOS, then see if it will show "windows" listed and try to boot it that way . . . . Or, in the case of OSX "not playing well with others," OSX installs go into the drive first, then linux and grub after. Since it doesn't take much time to run a linux install, you could try erasing the Manjaro partition and then see if you only have windows installed, will it boot?? If not, then maybe there is a problem with the windows install??? If it's an OEM windows computer then the mobo should first be looking for windows to boot, and then it might go to grub. But if grub went in with Manjaro install then grub is only going to boot . . . Manjaro. Manjaro seems to be fairly friendly to grub updates, but ubuntu hasn't been that great for multi-booting, it seems to wipe out all other contestants and just boot itself.

So, if you need to have grub boot windows I have no experience with that, I keep apples with apples and just use grub for linux, because the situation is usually "dynamic" and your work to enter the UUID numbers for windows into grub will likely get wiped with some upgrade, although having just windows and manjaro isn't too complicated to fix.

0

There has been some time since this and I've since then deleted Windows, but I figured out how to fix this. The general problem was NOT the realtime kernel, but rather windows updating (or setting an option when it was turned off) which caused both itself and linux to not be bootable.

After restoring Linux with a different installation media, and fixing grub, it couldn't boot into Windows because of that option, I think. If you come upon this and wish to get an answer, I suggest you use an installation media of Windows that you flashed either from a different PC, or a Phone (you can look up how to do that, it's rather handy. My problem was that I didn't have access to a PC and I didn't know a phone could flash an ISO to a USB, so I re-lay this information to you.)

Plug it in to your PC that has the non-working Windows partition, boot from USB, then on the initial setup screen, enter your language and other preferences, and then select Next. If you don't see the setup screen, your PC might not be set up to boot from a drive. Check your PC manufacturer's website for info on how to change your PC's boot order, and then try again.

Then select Repair your computer. On the Choose an option screen, select Troubleshoot. From there, you can restore from a system restore point by selecting Advanced options > System Restore. This will remove recently installed apps, drivers, and updates that might be causing your PC problems. Restoring from a restore point won’t affect your personal files.

Those steps were taken from here. If it doesn't work for you, or you have a different circumstance, you might want to look up something else, good luck to you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.