1

I have Ubuntu 20.10 on zfs root (upgraded from 20.04) I tried to restore 20.04 using zsys features at boot, which was unsuccessful. I have a backup (created using syncoid). Using zfs send/receive. I created a new pool in a separated disk called spool. It has a restored 20.04 before the upgrade.

I'd like to be able to choose at boot time between the two rpools. How to I set it up with grub.

1

The root is selected using the kernel boot parameter root=ZFS=pool/fsname. Simply add another grub entry with a different entry for different root.

7
  • Is there a way to make "update-grub" do it for me. The file /etc/grub.d/10_linux_zfs might be a good candidate for modification. I just do not know enough to make the changes. – user63726 Oct 25 '20 at 23:03
  • I tried to make the change manually. It fails to mount spool (the new rpool). It tied to mount it the root from spool on /root/spool/ROOT.. instead of / – user63726 Oct 29 '20 at 1:04
  • I suspect you forgot to set mount point=legacy on spool/ROOT. – Gordan Bobic Oct 29 '20 at 6:20
  • If I do that. I do not think that all the subpools and the user pools will be mounted. – user63726 Oct 31 '20 at 0:18
  • They aren't directly related. The root file system gets mounted by the initramfs under /sysroot during the initramfs stage. The other file systems get mounted after switchroot by systems via the zfs-import-cache and zfs-import-scan services. – Gordan Bobic Oct 31 '20 at 6:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.