3

When running Debian Buster 10 with 128 MB of memory get a Kernel Panic. However it works fine on 256 MB of memory. The output lines are:

? initrd_load+Ox5e/Ox5e 
ksys_write+Ox57/0xdO 
write+Ox29/0x5a 
do_copy+Ox9b/Oxc8 
write_buffer+Ox27/0x37 
flush_buffer+Ox34/0x8b 
__gunzip+Ox26e/0x315 
? bunzip2+0x397/0x397 
? initrd_load+Ox5e/Ox5e 
? __gunzip+Ox315/0x315 
gunzip+Oxe/Ox11 
? initrd_load+Ox5e/Ox5e 
unpack_to_rootfs+0x182/0x2c6 
? initrd_load+Ox5e/Ox5e 
? unpack_to_rootfs+0x2c6/0x2c6 
? do_early_param+0x8e/Ox8e 
populate_rootfs+0x59/0x10b 
do_one_initca11+0x46/0x1c3 
? do_early_param+0x8e/Ox8e 
kernel_init_freeable+Ox189/0x218 
? rest_init+Oxaa/Oxaa 
kernel_init+Oxa/Oxl0d 
ret_from_fork+Ox35/0x40 
  • When exactly are you getting this message? At boot? It looks like initrd ran out of room to decompress its image into RAM. How is your system set up? – ErikF Oct 24 at 6:12
4

The kernel is unable to decompress its initramfs, which it needs to boot in Debian’s default configuration.

The documented minimum amount of memory for Debian 10 on x86 is 256 MiB.

| improve this answer | |
  • Thank you. I was relying on the part of the documentation that said "The actual minimum memory requirements are a lot less than the numbers listed in this table." There used to be a time when you can start Ubuntu with 96 MB. The system does not even use 128 MB after startup. But I suppose that's what it takes today for a Debian system to boot up today. Appreciate the answer. – Senthil Oct 24 at 12:30
  • 2
    Right, but I suspect “a lot less” doesn’t extend as far as “half”. The actual requirements vary depending on the size of the initramfs, so you could try reducing that — look at /etc/initramfs-tools/initramfs.conf, in particular the MODULES setting. To take things further, you could build your own kernel with all the drivers required to mount the root file system built-in, then boot without an initramfs at all. – Stephen Kitt Oct 24 at 12:36
  • Thank you for the detailed explanation. I removed 4 of the 7 mount points and it still did not matter and ended with kernel panic. I do have the answer I needed that there is nothing funny about my install that is causing the issue. Happy to allocate the required memory. – Senthil Oct 24 at 21:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.