1

Debian 10 Buster

It looks there are a bunch of topics on WIFI Intel Corporation Wireless-AC 9260 and I went over them and still, I couldn't figure out my problem.

My Wifi connection was good. Then I played with the configuration to learn using nmcli and other tools and all went wrong. Now my network manager detects WIFI networks but is not connecting. I am connected to an ethernet port now from a hotspot.

Network-manager and network-manager-gnome seems to be running Firmware looks is there:

sudo dmesg | grep iwlwifi
[    8.290464] iwlwifi 0000:04:00.0: enabling device (0000 -> 0002)
[    8.354030] iwlwifi 0000:04:00.0: firmware: direct-loading firmware iwlwifi-9260-th-b0-jf-b0-38.ucode
[    8.354519] iwlwifi 0000:04:00.0: loaded firmware version 38.755cfdd8.0 op_mode iwlmvm
[    8.456600] iwlwifi 0000:04:00.0: Detected Intel(R) Dual Band Wireless AC 9260, REV=0x324
[    8.505714] iwlwifi 0000:04:00.0: base HW address: (i removed the numbers)
[    8.608357] iwlwifi 0000:04:00.0 wlp4s0: renamed from wlan0
sudo uname -r
4.19.0-12-amd64

I tried to remove firmware-iwlwifi, reinstall. NO effect. I reinstalled network-manager. No effect. I have no idea what is going on. Any help?thanks

[edit] Some more clues I found where this seems to be failing but I have not found the fix.

:~$ nmcli dev status
DEVICE  TYPE      STATE         CONNECTION 
eno1    ethernet  connected     eno1       
wlp4s0  wifi      disconnected  --         
lo      loopback  unmanaged     --  

The device wlp4s0 is disconnected I search how to connect, not clear, but I tried:

:~$ sudo nmcli dev connect wlp4s0
Error: Failed to add/activate new connection: A 'wireless' setting is required if no AP path was given.

So, it looks to me that if I can fix the "'wireless' setting" and connect wlp4s0 the problem may be fixed.

So, what are these settings and how to change them?

1
  • 1
    You likely wiped out your corresponding profile configurations. When you use nmcli dev connect wlp4s0 , network manager is only being told a starting point, i.e. use this partifuclar WIFI device to connect, but you never told it where to connect to (or how, i.e. password etc). There needs to be a preexisting connection profile (previously made and authenitcated connection, with preexisting settings) otherwise nmcli won't know where to go. See the answer below
    – Neticegear
    Oct 24 '20 at 4:47
1

First, you should check if your adapter can find your AP with

nmcli d wifi list

*  SSID             MODE   CHAN  RATE       SIGNAL  BARS  SECURITY
   [YOUR_SSID]      Infra   1   54 Mbit/s     99

If you cannot see your AP, then make sure your radio is on with

nmcli r wifi on

Once your AP is visible all you should have to do is:

nmcli d wifi connect [YOUR_SSID] password [your wifi password] ifname wlp4s0

Finally, once you connect, the connection profile should be added and visible among those displayed by:

nmcli c show
1

Thank you BarBar for your answer. +1 I tried that before and didn't work. However, I found that some settings were wrong in /etc/NetworkManager/NetworkManager.conf and after rebooting, all good. So, problem solved! Thanks again!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.