0

I installed Elementary OS alongside Windows 10 on the one logical partition / and elf partition. But when I reboot pc, I see grub rescue shell. I tried to type this commands:

set root=(hd0,msdos7)
set prefix=(hd0,msdos7)/boot/grub
insmod normal

on the last command i see error: file /boot/grub/i386-pc/normal.mod not found. I found normal.mod in folder /boot/grub/x86_64-efi/ and type:

insmod $prefix/x86_64-efi/normal.mod

and get error invalid arch-dependent elf magic After this I tried to re-install grub from live cd (while installation I saw that install x86_64 type instead of i386) Arch is not important for me. I just want to return ability to use my pc. Please help.

fdsik -l :

Disk /dev/sda: 465.8 GiB, 500107862016 bytes, 976773168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos
Disk identifier: 0x935f4825

Device     Boot     Start       End   Sectors   Size Id Type
/dev/sda1            2048   1126399   1124352   549M  7 HPFS/NTFS/exFAT
/dev/sda2         1126400 251660287 250533888 119.5G  7 HPFS/NTFS/exFAT
/dev/sda4       251662334 976771071 725108738 345.8G  f W95 Ext'd (LBA)
/dev/sda5       446973952 976771071 529797120 252.6G  7 HPFS/NTFS/exFAT
/dev/sda6  *    251662336 253614079   1951744   953M ef EFI (FAT-12/16/32)
/dev/sda7       253616128 446959615 193343488  92.2G 83 Linux

Partition 4 does not start on physical sector boundary.
Partition table entries are not in disk order.
2
  • Have you tried using rEFInd as your EFI boot manager, so that at least you can boot an OS? I should be able to boot any OS which installed an EFI executable in your EFI partition. Oct 23 '20 at 9:08
  • @EmmanuelRosa, thank you for answering. I don't undestend what about you say, but I hope your answer will help someone else, who is stupid like me. Thank you. I already found the solution
    – Grigory
    Oct 25 '20 at 18:32
0

Nothing difficult. No need to complicate anything!

sudo mount /dev/sda7 /mnt
sudo grub-install --root-directory=/mnt /dev/sda

And then:

sudo update-grub --output /mnt/boot/grub/grub.cfg

But after this I have on Windows excess Disk E with EFI folder. Well, to hell with him

1
  • I feel "to hell with it" can be a bit missleading: If one were to actually remove the partition, as opposed to just ignore that Windows gave it a drive letter, the computer would no longer boot.
    – Oskar Skog
    Oct 26 '20 at 1:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.