I heard that it should be not that hard to install Google Chrome and the latest Firefox on RHEL 5.4. (the OS our company support is only up to RHEL 5.4). It probably requires some make install and will uses the C compiler.

Can somebody give a definite and tested answer? (instead of some webpage that might not work or dated back to 2007).

Please also mention any required packages (probably yum packages) and how to install them.

  • Did you try the rpm from http://google.com/chrome? – jordanm Jan 17 '13 at 4:07
  • yes, and I tried downloading all 4 of those packages and nothing happens after the download. (using Firefox 3) – nonopolarity Jan 17 '13 at 4:33
  • What do you mean "nothing happens"? Did you install the package and try running google-chrome? – jordanm Jan 17 '13 at 4:57
  • The question is, how do you "install" the package? I am a newbie in RHEL / Fedora – nonopolarity Jan 17 '13 at 7:37

Use Google's Chrome Yum repository.

Create a file /etc/yum.repos.d/google-chrome.repo with the following contents:


Now you can install google-chrome-stable, or if you feel like taking some risks, you can install google-chrome-beta or google-chrome-unstable.

  • When I try this, I get the following error: dl.google.com/linux/chrome/rpm/stable/x86_64 /repodata/repomd.xml: [Errno 4] IOError: <urlopen error (-2, 'Name or service not known')> Trying other mirror. Error: Cannot retrieve repository metadata (repomd.xml) for repository: google-chrome. Please verify its path and try again – Graeme Perrow May 23 '13 at 15:44
  • @GraemePerrow Works for me (and everyone else). Check your computer's nameservers and general Internet connectivity. – Michael Hampton May 23 '13 at 15:50
  • Probably has something to do with my company's firewall and proxy settings and such. Thanks anyway – Graeme Perrow May 23 '13 at 16:59
  • @GraemePerrow Yeah, that would do it. Make sure you've specified the company proxy server in your yum configuration. If you need further help, you should probably ask a new question, or contact your IT department. – Michael Hampton May 23 '13 at 17:03

If you have downloaded that package, run rpm -ivh package_name.rpm. Or click System/Administration/AddRemove Software, use the GUI tool to search 'chrome' package.


On adding my company proxy in vi /etc/yum.conf, i was able to install chrome example: proxy=http://proxysvr.yourdom.com:3128


I followed a process which worked for me.

I am using Redhat 7.4, and I've been through a lot to uninstall and install chrome and firefox, got partially successful with chrome and this is what I tried.

In the Linux terminal

Go to the root by typing

su -

Then type

rpm -qa

then (ctrl+f) and search for the keywords "google" or " chrome" or "mozilla" or "firefox" to check whether they are present or not and if they are available, then uninstall (remove) them by the following command (If you want to remove them)

yum remove [Package Name]

this removes the application

Then install chrome by the following process

type this in terminal

wget https://dl.google.com/linux/direct/google-chrome-stable_current_x86_64.rpm

then a package gets downloaded in your current working directory

Then type the following command - this installs the packages

yum -y install [Package You just Downloaded]

in this case it will be

yum -y install google-chrome-stable_current_x86_64.rpm

This installs google chrome and creates an icon under Application->Internet->googleChrome


Technically, by clicking this googlechrome icon- this should open the browser, but it doesn't open the browser for me, I dont know whats the problem and I appreciate any suggestion regarding this issue.

I open google chrome through terminal using this command

google-chrome --no-sandbox

this opens the chrome browser.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.