1

On my MX Linux XFCE environment I have the problem that after a certain time without interaction after power on the HDMI signal is lost and can only be retrieved with pressing a keyboard key. I would that the HDMI signal or display never switched off. I have already deactivated DPMS and the screensaver. Apparently this is not enough. Do you have any ideas about the possible cause? I'm using a nvidia optimus card if this information is relevant.

$ xset -q
...
Keyboard Control:
  auto repeat:  on    key click percent:  0    LED mask:  00000000
  XKB indicators:
    00: Caps Lock:   off    01: Num Lock:    off    02: Scroll Lock: off
    03: Compose:     off    04: Kana:        off    05: Sleep:       off
    06: Suspend:     off    07: Mute:        off    08: Misc:        off
    09: Mail:        off    10: Charging:    off    11: Shift Lock:  off
    12: Group 2:     off    13: Mouse Keys:  off
  auto repeat delay:  500    repeat rate:  20
  auto repeating keys:  00ffffffdffffbbf
                        fadfffefffedffff
                        9fffffffffffffff
                        fff7ffffffffffff
  bell percent:  50    bell pitch:  400    bell duration:  100
Pointer Control:
  acceleration:  22/5    threshold:  4
Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  0    cycle:  600
Colors:
  default colormap:  0x22    BlackPixel:  0x0    WhitePixel:  0xffffff
Font Path:
  /usr/share/fonts/X11/misc,/usr/share/fonts/X11/100dpi/:unscaled,/usr/share/fonts/X11/75dpi/:unscaled,/usr/share/fonts/X11/Type1,/usr/share/fonts/X11/100dpi,/usr/share/fonts/X11/75dpi,built-ins
DPMS (Energy Star):
  Standby: 600    Suspend: 600    Off: 600
  DPMS is Disabled


$ xdg-screensaver status
disabled
2
  • Could you post the complete output of xset -q? Oct 22, 2020 at 14:27
  • @hedgie Done :)
    – Mike
    Oct 22, 2020 at 17:25

1 Answer 1

0

Your output shows that DPMS is disabled, so your monitor isn't receiving the "turn yourself off" signal from X. However, your X server is still set to "sceen blanking", as shown by the following bit in the output of xset -q:

Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  0    cycle:  600

The following commands will disable all of this, as well as disable sending DPMS commands:

$ xset s off
$ xset s 0 0
$ xset -dpms

Put them in your ~/.xsessionrc file to run these commands automatically at startup.

1
  • Thank you I will try this. Is there a file for a system wide effect instead of ~/.xsessionrc? Can i also paste the commands into /etc/X11/Xsession.options ? Update: After I enter the commands the xset -q command show me the same settings as before.
    – Mike
    Oct 22, 2020 at 20:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .