0

I'm running latest Pop OS using i3 as my window manager and Gnome is also installed and I have configured 00-keyboard.conf for layout (us,ru) and switching method and using gxkb as indicator.I also need to load a modified Xmodmap in i3 config for more intuitive layout.So in Gnome everything works as it should, but in i3 loading Xmodmap adds an extra keyboard tap to cycle through the layouts. For example, without xmodmap , one tap - 'us', on tap 'ru', one tap 'us' and so on. But with loaded xmodmap it takes one extra step to get back to 'us'. I don't seem to find information on this. Any ideas?

Any help would be appreciated.

P.S. It seems that gxkb stays on 'ru' while the keyboard already prints English letters. So keyboard switches two times to 'us' and then to 'ru' and layout indicator does the opposite - two times on 'ru' and then 'us'.

1
  • 1
    I've rolled back your tagging of the title with "(solved)". Accept the answer that solved the issue instead. Do that by clicking on the grayed out checkmark by the answer.
    – Kusalananda
    Oct 23, 2020 at 23:21

2 Answers 2

0

I suggest you to let gnome do the work for you: I use Xfce+i3 and it works perfectly, in xfce i've only changed the window manager, switching from Xfwm to i3; the rest of the GUI things are managed by xfce. Probably gnome is not very modular, but i think installing i3 on top of gnome would be more convenient. I found this and i think will be userful to switch from gnome to i3: https://github.com/i3-gnome/i3-gnome

5
  • That's interesting. I will definitely check it out. Thanks for the tip. đź‘Ť
    – Evgeny K
    Oct 21, 2020 at 16:31
  • I've tried i3-gnome, but, unfortunately, it doesn't seem to work for me. First off, latest Pop OS/Ubuntu is shipped with Gnome 3.36 and this project utilizes Gnome 3.38.x. Not sure, if that's why I see no changes, 'cause I don't see anything different from what I've had before. I can't even make system tray show up on my polybar. And , obviously, keyboard issue is still there.
    – Evgeny K
    Oct 22, 2020 at 21:36
  • at this point i think you should consider using another DE to use with i3 Oct 22, 2020 at 22:55
  • I've just tested it on Arco Linux i3wm and XFCE as a base DE and its the same behavior. With polybar xkeyboard module enabled as indicator, loaded modified xmodmap adds one extra tap to get back to 'us'. And it shows as an empty indicator. Don't understand, what is going on. I've installed xkblayout-state from here and it crashes once I try to run it whenever this empty state occurs.
    – Evgeny K
    Oct 23, 2020 at 1:37
  • xkblayout-state print %S prints out 3 layouts - us_US, us, ru. What is us_US layout?
    – Evgeny K
    Oct 23, 2020 at 1:49
0

The only solution I found right now is to manually edit /usr/share/X11/xkb/symbols/ru file. Maybe not the most elegant and smart way to fix this issue, but functional and works for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.