0

Background: I'm running Fedora 32 on a Thinkpad. Current kernel version is as follows:

Linux 5.8.4-200.fc32.x86_64 x86_64

Problem: It was working as expected for several months, but now when I run dnf update the following error is given:

Error: 
 Problem 1: package kernel-modules-extra-5.7.15-200.fc32.x86_64 requires kernel-uname-r = 5.7.15-200.fc32.x86_64, but none of the providers can be installed
  - conflicting requests
 Problem 2: package kernel-5.7.15-200.fc32.x86_64 requires kernel-core-uname-r = 5.7.15-200.fc32.x86_64, but none of the providers can be installed
  - conflicting requests 

Current situation / what I've tried: My (current, likely incorrect) understanding is that this older kernel package is being specified by some other package, and can't be installed because it's older and does not appear in the default repos.

I can get non-kernel packages to update by running dnf --excludepkgs=kernel\* , but I'd like to 1) understand, and 2) fix this error so that I can get kernel updates normally.

I have researched the error somewhat (see links below), but none of the similar conflict errors match my situation very closely, and I'm reluctant to remove or disable the denoted module(s) without understanding what that might do.

All guidance much appreciated!

Links I've investigate to date:

(https://www.linux.org/threads/how-to-fix-problem-conflicting-requests-on-dnf-install-on-centos.29322/)

("package X requires Y, but none of the providers can be installed")

(https://askbot.fedoraproject.org/en/question/133821/dnf-upgrade-conflicting-requests/)

(yum update returns kernel error) NOTE: this one looks similar, but the config file fix suggested here is not applicable to my configuration

1
  • 1
    Try running dnf update --best --allowerasing the --allowerasing option will tell dnf to remove packages to solve dependencies. At least it should tell you what depends on the "broken" kernel. Oct 18, 2020 at 6:10

1 Answer 1

0

Try this:

dnf remove $(rpm -qa | grep 5.7.15-200)
1
  • This resolved the issue, thanks! Oct 19, 2020 at 17:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.