4

I am trying to print over Wi-Fi to an HP Photosmart D110 printer which is successfully recognized by CUPS. But I only get a sheet with the error message Unable to open the initial device, quitting. And in the CUPS interface it says Filter failed.

At home I have an HP Photosmart C3100 that works correctly over USB, so I think CUPS is not the problem. I have tried to no avail:

  • reinstalling cups/hplip
  • pacman -S avahi nss-mdns (like proposed here)

The full text of /var/log/cups/error_log is here. The same printer works correctly over USB, too.

I'm running Arch Linux x86-64 with cups 1.6.1. What am I missing?

2
  • Versions of cups on your machine and the server?
    – jasonwryan
    Jan 16, 2013 at 18:05
  • I'm not using a print server (the printer has its own embedded print server). cups on my machine is 1.6.1
    – Renan
    Jan 16, 2013 at 18:10

1 Answer 1

6

Solved by using the hpcups driver rather than the hpijs one (picked when configuring the printer).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .