3

I'm trying to create an apk package. I followed the Alpine Linux - Creating an Alpine package HOWTO.

I think everything is set up as needed. When I try to build package, I get an error:

abuild -r
mypackage: Building jaur/mypackage 3.10.5-r0 (using abuild 3.6.0-r2) started Sat, 17 Oct 2020 15:00:13 +0300
mypackage: Checking sanity of /home/jaur/test/APKBUILD...
mypackage: Analyzing dependencies...
ERROR: mypackage: builddeps failed
libdigidoc: Uninstalling dependencies...
ERROR: No such package: .makedepends-mypackage

In APKBUILD i have on "makedepends" line:

makedepends="git openssl-dev libxml2-dev doxygen 
cmake make gcc bash xxd swig minizip-dev boost-dev 
openjdk10-jdk openldap-dev qt5-qttools-dev 
qt5-qtsvg-dev pcsc-lite-dev xerces-c-dev zip"

I also tried, for testing, to build the flac package. I'm sure in aports/main/flac APKBUILD is correct. I didn't change anything there, but I'm getting the same error:

>>> flac: Building main/flac 1.3.3-r0 (using abuild 3.6.0-r2) started Sat, 17 Oct 2020 14:59:14 +0300
>>> flac: Checking sanity of /home/jaur/aports/main/flac/APKBUILD...
>>> flac: Analyzing dependencies...
>>> ERROR: flac: builddeps failed
>>> flac: Uninstalling dependencies...
ERROR: No such package: .makedepends-flac

Am I doing something wrong, missing some step(s) or something?

0

1 Answer 1

2

My main problem was that I had one broken package in my system. I removed it and everything works. Also, it would help running apk fix. Word of advice: use clean environment, so that you don't have old .so lying around in the filesystem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .