0

I've been a linux user for the past 5 years.So I don't shy from the cli and troubleshooting issue. It's been a week and when I had tested out a lot of permutation and combinations of what could work and it didn't pan out, so I thought of posting it online, for help.

General Laptop Spec

I am was on a dual boot ( windows 8.1 + ubuntu 20.04 ) laptop HP ab032tx, with NVIDIA 940mx graphics card, with propriety drivers, nvidia 450.

Earlier I had open source drivers ( not sure about this though ).

I've been running ubuntu 20.04 from the very start of it's launch in April 2020. There weren't any issue till a week back.

One fine day I suspended my laptop and the next time I open it I see some error regarding

DMAR: [Firmware Bug]: No firmware reserved region can cover this, contact BIOS vendor for fixes 
~~~~ Some other content here ~~~~
[drm:fw_domains_get [i915]] *ERROR * render: timed out waiting forcewake ack to clear

The initial suggestion I found was to use nouveau.modeset=0 through editing the GRUB menu. It did log me in to the system but only once.

I checked a lot of sources :

  1. Arch IOMMU solved - arch forums
  2. DMAR Firmware Bug
  3. Firmware Bug / BIOS is Broken
  4. Update your kernel - SO
  5. Fedora - install lm_sensor - Solved - Reddit

Initial Conclusion

  • BIOS update should work fine.
  • Change the kernel version
  • NVIDIA drivers are the culprit.

I acted on both of these one-by-one in the last one week.

Troubleshooting Process

BIOS update

  • Updated the bios to latest using HP Assistant Didn't help.

Upgrade the kernel

  • Logged into recovery mode and did a kernel upgrade, actually added a new update kernel, using ukupgrade
  • Didn't help much.

I could log in using the older kernel ( I think it was 5.2.xx or sth ) but that too intermittently, like 1 in 3 times.

NVIDIA drivers are the culprit

Earlier I could install ubuntu , so I installed a fresh copy of ubuntu 20.04 and then installed propriety drivers of NVIDIA i.e. nvidia 450. After reboot it started getting stuck again.

Changing OS

Arch & Manjaro Linux

I tried arch linux first but that got stuck the same place Then tried Manjaro ( although it was built on Arch, I thought maybe more stable ), stuck at the same place.

Pop!_OS

Tried 20.04 nvidia version, it got stuck at the same place as other OSes I read that they've an NVIDIA variant, thought this must be stable. Then I thought of installing with an older kernel so downloaded 18.04. It got stuck here : stuck with pop_os

Would be extremely grateful if anyone could help me troubleshoot this issue. A lot of my work depends on this.

Thanks.

Update

From discussion in comments it seems that the issue is with i915 Intel GPU Drivers. I had tried installing this using Windows and HP assistant but it crashed even there.

Also how would I install it, if I am not able to install the linux OS itself :?

  • Do you have i915 firmware drivers installed? – Sysadmin Oct 15 at 8:32
  • I don't know that, do I've to install it separately 🤔 I mean it was working fine till last week for the past 6 months, why would it be required suddenly. I would check that definitely. Any link for installation instructions regarding that 🤔 – temporarya Oct 15 at 8:57
  • @Sysadmin Also how do I install those, if i am not able to install any OS itself 😅 – temporarya Oct 15 at 8:59
  • According to your latest photo, you've got issues with your Intel iGPU, not NVIDIA. Please try installing Fedora 33 beta as it contains the freshest kernel among all other distros. Also, why can't you just install Windows? Why all the troubles with an OS which often breaks down inexplicably? – Artem S. Tashkinov Oct 15 at 9:58
  • @ArtemS.Tashkinov thanks. How did you conclude that, i did understand some issue with i915 but don't know how to solve that :/ – temporarya Oct 15 at 10:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.