6

I switch language layouts by pressing Alt+Shift and it's infuriating when after pressing alt my focus goes to some settings (especially in Skype)

Instead of staying in the text input it focuses ALT menu

alt menu

To get back i have to remember to press ALT again

How can I disable this functionality?

OS: Linux Ubuntu 20.04

2

1 Answer 1

4

Create the file

~/.config/gtk-3.0/settings.ini

and add the following to it

[Settings]
gtk-enable-mnemonics = 0

If you want the settings to apply to all users, you can put in /etc/gtk-3.0/settings.ini instead.

Restart the X session once done.

Adapted/Stolen from https://askubuntu.com/a/569310 (go there and give it an upvote!).

4
  • Does not work unfortunately :/
    – ccvhd
    Oct 14, 2020 at 17:17
  • @dhvcc Then I wonder if Skype actually uses GTK or something else. Have you tried it in Firefox, for example?
    – Quasímodo
    Oct 19, 2020 at 15:35
  • Skype does not support firefox for the web version :c
    – ccvhd
    Oct 20, 2020 at 8:25
  • @dhvcc I see, but I mean that Firefox uses GTK, so if you test the solution on Firefox (without Skype), it should work.
    – Quasímodo
    Oct 20, 2020 at 11:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .