0

I installed ffmpeg this way:

apt-get install ffmpeg

My distribution is:

Linux debian3 4.19.0-9-amd64 #1 Debian 4.19.118-2+deb10u1 (2020-06-07) x86_64 GNU/Linux

The issue is, when I want to run ffplay file.pcm I end with the error message:

error: XDG_RUNTIME_DIR not set in the environment.
Could not initialize SDL - No available video device
(Did you set the DISPLAY variable?)

I tried with different audio files (mp3, wav), the output is always the same.

5
  • try -vo null? – Artem S. Tashkinov Oct 13 '20 at 14:33
  • @ArtemS.Tashkinov. Failed to set value 'null' for option 'vo': Option not found. -vn also failed. – alpereira7 Oct 13 '20 at 14:41
  • Are you using ffmpeg or ffplay or something else? What exactly are you doing? The ffmpeg package contains utilities and libraries. – Artem S. Tashkinov Oct 13 '20 at 14:56
  • @ArtemS.Tashkinov, sorry and thanks. I updated my question. – alpereira7 Oct 19 '20 at 8:20
  • ffplay -vn file should work. Does it fail with the same message? I'd compile ffmpeg from sources then. Looks like debian package is broken. – Artem S. Tashkinov Oct 19 '20 at 10:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.