1

I have some problems installing Nvidia drivers on my Kubuntu system and to get them working (GPU-Model: GeForce GTX 980 Ti). I tried it first in the standard way:

$ sudo add-apt-repository ppa:graphics-drivers/ppa
$ sudo apt-get update
$ sudo apt-get install nvidia-driver-450

The installation finished, but after restarting, the new drivers don't work very well. I'm using a 4K monitor with 3840x2160 (16:9) resolution, but with the driver in use, it only allows for a resolution of 1024x768 (4:3), so my whole screen gets distorted. Also, the command nvidia-smi fails:

NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

Furthermore, after removing the drivers manually and restart, everything is back to normal. I tried with this method instead: $ sudo ubuntu-drivers autoinstall, but I get the same results. Then, I tried to execute the runfile provided by NVIDIA on their download site, but it fails because it is unable to disable Nouveau (the current Kernel driver in use).

I also executed this command: lspci -vnn | grep VGA -A 12 to check. This is what I get when running normal:

And here the same output with NVIDIA drivers enabled:

01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GM200 [GeForce GTX 980 Ti] [10de:17c8] (rev a1) (prog-if 00 [VGA controller])
        Subsystem: NVIDIA Corporation GM200 [GeForce GTX 980 Ti] [10de:17c8]
        Flags: bus master, fast devsel, latency 0, IRQ 11
        Memory at f6000000 (32-bit, non-prefetchable) [size=16M]
        Memory at e0000000 (64-bit, prefetchable) [size=256M]
        Memory at f0000000 (64-bit, prefetchable) [size=32M]
        I/O ports at e000 [size=128]
        Expansion ROM at 000c0000 [disabled] [size=128K]
        Capabilities: <access denied>
        Kernel modules: nvidiafb, nouveau

01:00.1 Audio device [0403]: NVIDIA Corporation GM200 High Definition Audio [10de:0fb0] (rev a1)
        Subsystem: NVIDIA Corporation GM200 High Definition Audio [10de:17c8]

Any advice how to get the NVIDIA drivers installed and working on Kubuntu? I tried pretty much every installation guide, but none of them really worked.

1 Answer 1

0

Kernel modules: nvidiafb, nouveau

  1. You haven't blacklisted nouveau - please try adding nouveau.modeset=0 nomodeset to your GRUB flags

  2. Make sure the NVIDIA driver has been compiled and installed successfully.

To check it:

grep nvidia /lib/modules/`uname -r`/modules.alias
alias pci:v000010DEd*sv*sd*bc0Csc80i* i2c_nvidia_gpu
alias pci:v000010DEd*sv*sd*bc03sc02i00* nvidia_drm
alias pci:v000010DEd*sv*sd*bc03sc00i00* nvidia_drm
alias char-major-195-* nvidia
alias pci:v000010DEd*sv*sd*bc03sc02i00* nvidia
alias pci:v000010DEd*sv*sd*bc03sc00i00* nvidia

In a perfect world everything should have been done automatically. Have you actually rebooted after installing the driver? You must have done that.

4
  • Hello, of course I did restart, that's where the problem is coming from. Where can I edit my Grub flags? I haven't done this before.
    – Totemi1324
    Oct 13, 2020 at 17:27
  • I tried to apply, but the suggested changes don't work. Even after adding to the flags and generating the new config file, I get the same result. The command you wrote gives be this output: alias mbp_nvidia_bl apple_bl alias pci:v000010DEd*sv*sd*bc03sc*i* nvidiafb alias typec:id0955m* typec_nvidia alias pci:v000010DEd*sv*sd*bc0Csc80i* i2c_nvidia_gpu
    – Totemi1324
    Oct 16, 2020 at 7:57
  • NVIDIA kernel modules haven't compiled for you. No idea why as I don't use Ubuntu. Oct 16, 2020 at 12:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .