3

I'm running Pop OS on a Lenovo T495s. My onboard microphone was working fine but after updating to 20.04 I am getting no sound from it.

When I run pavucontrol I see two input devices:

  • Digital Microphone - Family 17h (Models 10h-1fh) Audio Controller Digital Microphone. Shows no input.
  • Headphones Stereo Microphone (unplugged) - Family 17h (Models 10h-1fh) HD Audio Controller Headphones Stereo Microphone. This does show input.

I'm not quite sure what the first devices is and it seems like I want to use the bottom one but only "Digital Microphone" is available to select in the OS Sound settings, or when using a microphone in a browser.

Why is the second microphone not available to use?

1
  • I have the same problem on my HP Probook 455 G7 with Kubuntu 20.04. I cannot set the "Headphones Stereo Microphone" as default for my system. But I can choose to use it as sound input from individual programs.
    – keypress
    Oct 13, 2020 at 17:47

2 Answers 2

2

I had the same problem with Ubuntu 20.04. What I did was to update the linux kernel. If you type

uname -a

to find out which version you have, then see if you are on 5.6 or 5.8

I was on 5.6-1020 and then updated to 5.8 by using the following command:

sudo apt install linux-image-5.8.0-23-generic linux-headers-5.8.0-23-generic linux-buildinfo-5.8.0-23-generic linux-modules-5.8.0-23-generic linux-modules-extra-5.8.0-23-generic

I noticed that in PulseAudio Volume Control, I can now actually disable the non working microphone under the configuration tab. Whereas before I couldn't.

3
  • That sort of worked. I am now able to see "Internal Microphone" in the Sound Settings dialog and it appears to be getting some input. However the only input I am able to select in a browser is the output monitor.
    – Mr_Chimp
    Oct 18, 2020 at 11:31
  • 1
    Oh wait! Now it works. Not sure what else I did but that seems to have done it. Thanks!
    – Mr_Chimp
    Oct 18, 2020 at 11:36
  • 5.8 doesn't seem sufficient for me, I see the headphones microphone as being unplugged in puvacontrol... and yet it detects some sound.
    – Eric Burel
    Sep 8, 2021 at 19:37
0

I had the same problem on HP Probook 455 G7 with Kubuntu 20.04. Updating to the upstream kernel 5.9.1 solved this issue for me https://wiki.ubuntu.com/Kernel/MainlineBuilds#How_do_I_install_an_upstream_kernel.3F

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.