0

I am using Linux Mint 20 Cinnamon and I am trying to hide the GRUB menu. I have also Windows 10 installed.

According to the official GRUB documentation, if the GRUB_TIMEOUT_STYLE is set to hidden the GRUB menu should not appear.

‘GRUB_TIMEOUT_STYLE’

If this option is unset or set to ‘menu’, then GRUB will display the menu and then wait for the timeout set by ‘GRUB_TIMEOUT’ to expire before booting the default entry. Pressing a key interrupts the timeout.

If this option is set to ‘countdown’ or ‘hidden’, then, before displaying the menu, GRUB will wait for the timeout set by ‘GRUB_TIMEOUT’ to expire. If ESC is pressed during that time, it will display the menu and wait for input. If a hotkey associated with a menu entry is pressed, it will boot the associated menu entry immediately. If the timeout expires before either of these happens, it will boot the default entry. In the ‘countdown’ case, it will show a one-line indication of the remaining time.

By default the configurations of my /etc/default/grub file had GRUB_TIMEOUT_STYLE set to hidden but still it is not hidden. I tried adding GRUB_HIDDEN_TIMEOUT=0 AND GRUB_HIDDEN_TIMEOUT_QUIET=true but as expected it has no effect.

My /etc/default/grub file is as shown below

# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

GRUB_BACKGROUND="/home/aniketsharma00411/Volume/Aniket/Wallpaper/abstract-laser.jpg"

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

I know an easy solution is to set the timeout to 0 but that will not enable me to get to menu when I want to. I just want to ask why the GRUB_TIMEOUT_STYLE=hidden not working when it very much should according to GRUB documentation.

P.S.: Yes I am using update-grub after making changes.

1 Answer 1

0

Add this line to /etc/default/grub:

GRUB_RECORDFAIL_TIMEOUT=0

Update and reboot:

sudo update-grub
sudo reboot

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .