0

I am trying to create a partition on a physical hard drive.

Here is the output I gent when I use print

(parted) print                                                            
Error: /dev/sdd: unrecognised disk label
Model: USB3.0 Super Speed (scsi)                                          
Disk /dev/sdd: 2000GB
Sector size (logical/physical): 512B/512B
Partition Table: unknown
Disk Flags: 

I tried:

$ sudo parted /dev/sdd
(parted) mklabel msdos                                                    
Error: Input/output error during write on /dev/sdd

I also tried to repair the drive with:

$ sudo badblocks -v /dev/sdc > bad_sectors.txt

It gived me a 11G output file

$ ll -h
total 11G
drwxrwxr-x  3 bric bric 4,0K oct.  10 08:23 ./
drwxr-xr-x 34 bric bric 4,0K oct.  10 07:56 ../
-rw-rw-r--  1 bric bric  11G oct.  10 09:28 bad_sectors.txt

I tryied also this:

$ sudo e2fsck -cfpv /dev/sdd
e2fsck: Bad magic number in super-block while trying to open /dev/sdd
/dev/sdd: 
The superblock could not be read or does not describe a valid ext2/ext3/ext4
filesystem.  If the device is valid and it really contains an ext2/ext3/ext4
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
    e2fsck -b 8193 <device>
 or
    e2fsck -b 32768 <device>

Having the same error by using e2fsck -b 8193 and e2fsck -b 32768.

And I also tried to use the bad_sectors.txt file:

sudo e2fsck -l bad_sectors.txt /dev/sda1

But I had the same error as above.

Here is the filesystem:

$ fsck -N /dev/sdc
fsck from util-linux 2.34
[/usr/sbin/fsck.ext2 (1) -- /dev/sdc] fsck.ext2 /dev/sdc 

Any clue to solve this issue ?

3
  • 2
    Have you tried to run smart test on the disk? But it looks like the disk is dead. Oct 10, 2020 at 10:50
  • 2
    -rw-rw-r-- 1 bric bric 11G oct. 10 09:28 bad_sectors.txt - your drive is dead. Oct 10, 2020 at 11:35
  • Many SSD need firmware update to work with Linux. Have you checked that you have newest firmware on SSD? Also the only reason to use MBR(msdos) is if you want to boot Windows in old BIOS mode. Otherwise gpt is better. sudo parted /dev/sdd mklabel gpt.
    – oldfred
    Oct 10, 2020 at 13:54

0

You must log in to answer this question.

Browse other questions tagged .