3

I bought a brand new laptop and tried installing Ubuntu 20.04 on it (via bootable usb), however I experience frequent issues which render the system unusable, ie:

  • everything freezes (including mouse cursor, ctrl+alt+f1 combination doesn't work), followed by reboot after about 10s
  • laptop suddenly reboots
  • various things keep crashing (gnome-terminal-server, gnome-session, etc.) The issues happen at random times, first two even during the OS installation. Sometimes immediately after the system starts, sometimes after a few minutes.

I spent a few days trying to approach the problem from different angles without any success, and would really appreciate some advice on what avenues are worth further exploration and how. If it is likely a hardware issue it would be great to have a way to somehow prove it.

The facts:

  1. Some occurrences seem to correlate with "Hardware Error" entry in syslog (although I found some very similar entries which didn't seem to trigger the issue).
Oct  9 14:38:36 test-Lenovo-Legion-5-15IMH05H kernel: [  629.400829] mce: [Hardware Error]: Machine check events logged
Oct  9 14:38:36 test-Lenovo-Legion-5-15IMH05H rasdaemon[726]: rasdaemon: register inserted at db
Oct  9 14:38:36 test-Lenovo-Legion-5-15IMH05H rasdaemon[726]:            <...>-2740  [004]     0.000063: mce_record:           2020-10-09 14:38:37 +0200 bank=2, status= c000014000010019, Generic TLB Level-1 Error, mci=Error_overflow Corrected_error, mca=Generic TLB Level-1 Error, cpu_type= Intel generic architectural MCA, cpu= 4, socketid= 0, mcgstatus=0, mcgcap= c0c, apicid= 8
  1. In order to have some indication whether it can be a hardware issue I installed a Windows 10 Home on the laptop. Installation succeeded, OS spent a few hours downloading and installing updates, and generally seemed fine. In order to ensure that it works under stress I used Windows for a few hours, including playing Witcher 3 for about half an hour without any problems.

Some of my attemps to diagnose/fix the issue:

Disclaimer: my understanding of Linux is limited, in my attempts I followed some tutorials/guides, but I might have as well made some silly mistakes which render my conclusions wrong

  1. I tried to install the other kernels (5.8.14 and 5.9-rc8) by downloading the deb files, running dpkg -i linux*.deb and choosing the other kernel in boot menu; installation succeeded but didn't help
  2. I tried to install Manjaro Gnome (kernel 5.6) without success (it froze during installation, then it just didn't boot so I gave up)
  3. I did some experiments when I tried to install Ubuntu without propertiary GPU drivers, and then manually install Nvidia "Long Lived" drivers (v450) or "Short Lived" drivers (v455); in both cases installation completed, but it didn't seem helpful
  4. I tried Ubuntu 20.10 which had exactly same issues
  5. I tried various combinations of Linux kernels and NVidia drivers, including the latests ones on arch-linux
  6. Some resources suggested power related problem. The only thing that came to my mind was to try using laptop without DC adapter attached, but I still experienced freezes/reboots.

The logs

Here's the output of inxi -F && dmesg | grep -i error on minimal 20.04 with "Install propertiary drivers" enabled during installation.

System:    Host: test-Lenovo-Legion-5-15IMH05H Kernel: 5.4.0-48-generic x86_64 bits: 64 Desktop: Gnome 3.36.4 
           Distro: Ubuntu 20.04.1 LTS (Focal Fossa) 
Machine:   Type: Laptop System: LENOVO product: 81Y6 v: Lenovo Legion 5 15IMH05H serial: <superuser/root required> 
           Mobo: LENOVO model: LNVNB161216 v: NO DPK serial: <superuser/root required> UEFI: LENOVO v: EFCN32WW 
           date: 05/11/2020 

Battery:   ID-1: BAT0 charge: 61.4 Wh condition: 63.3/60.0 Wh (105%) 
CPU:       Topology: 6-Core model: Intel Core i7-10750H bits: 64 type: MT MCP L2 cache: 12.0 MiB 
           Speed: 800 MHz min/max: 800/5000 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 
           9: 800 10: 800 11: 800 12: 800 
Graphics:  Device-1: Intel UHD Graphics driver: i915 v: kernel 
           Device-2: NVIDIA TU106 [GeForce RTX 2060] driver: nvidia v: 450.66 
           Display: x11 server: X.Org 1.20.8 driver: modesetting,nvidia unloaded: fbdev,nouveau,vesa 
           resolution: 1920x1080~144Hz 
           OpenGL: renderer: GeForce RTX 2060/PCIe/SSE2 v: 4.6.0 NVIDIA 450.66 
Audio:     Device-1: Intel Comet Lake PCH cAVS driver: snd_hda_intel 
           Device-2: NVIDIA TU106 High Definition Audio driver: snd_hda_intel 
           Sound Server: ALSA v: k5.4.0-48-generic 
Network:   Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi 
           IF: wlp0s20f3 state: up mac: <REDACTED> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 
           IF: enp8s0 state: down mac: <REDACTED> 
Drives:    Local Storage: total: 476.94 GiB used: 8.08 GiB (1.7%) 
           ID-1: /dev/nvme0n1 vendor: Western Digital model: PC SN730 SDBQNTY-512G-1001 size: 476.94 GiB 
           ID-2: /dev/nvme1n1 vendor: SK Hynix model: HFM512GDHTNI-87A0B size: 476.94 GiB 
Partition: ID-1: / size: 468.00 GiB used: 8.01 GiB (1.7%) fs: ext4 dev: /dev/nvme0n1p2 
Sensors:   System Temperatures: cpu: 41.0 C mobo: N/A gpu: nvidia temp: 39 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 322 Uptime: 2m Memory: 31.23 GiB used: 1.32 GiB (4.2%) Shell: bash inxi: 3.0.38 
[    0.012647] [Firmware Bug]: TSC ADJUST differs within socket(s), fixing all errors
[    0.362528] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.I2C2.TPD0], AE_NOT_FOUND (20190816/dswload2-162)
[    0.362528] ACPI Error: AE_NOT_FOUND, During name lookup/catalog (20190816/psobject-220)
[    0.362528] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.I2C3.TPL1], AE_NOT_FOUND (20190816/dswload2-162)
[    0.362528] ACPI Error: AE_NOT_FOUND, During name lookup/catalog (20190816/psobject-220)
[    0.925916] RAS: Correctable Errors collector initialized.
[    6.754956] usb 1-6: device descriptor read/64, error -71
[    8.093725] EXT4-fs (nvme0n1p2): re-mounted. Opts: errors=remount-ro
[    8.399155] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-QuZ-a0-hr-b0-50.ucode failed with error -2
[    8.399445] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-QuZ-a0-hr-b0-49.ucode failed with error -2
[    9.295155] nvidia-gpu 0000:01:00.3: i2c timeout error e0000000
[    9.295162] ucsi_ccg: probe of 0-0008 failed with error -110

Thank you in advance

1 Answer 1

1

TL;DR I came to the conclusion that it's likely a hardware issue and decided to return the laptop.

Full story:

  • After some investigation I got an impression that the problem was related to the Nvidia GPU, as when I was using Intel it wasn't happening for a day or two.
  • A friend advised me to update BIOS; after doing that and updating NVidia drivers, everything worked fine for a few days, with only one odd restart and a few Gnome crashes
  • at some point I allowed the system to install system updates, and the issue started happening more often again, on both NVidia and Intel GPUs; for the record on that update Nvidia driver was bumped from 450.66.XX to 450.80.02, but I wasn't sure anymore if it's related to the issue
  • I noticed that the MCE error most of the time correlated with the reboots, happened very often and always on CPU 4; I assumed that it was most likely what makes the laptop unusable and started the return process.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.