I have an issue creating VMs on CentOS using Boxes with the following error:

Blockquote Virtualization extensions are unavailable on your system. Check your BIOS settings to enable them.

Also, when I try to use Virtual Machine Manager it says that KVM ins not available, while I did install it and it's running with all needed libs.

I wanted to access BIOS but there is a password on it (the laptop I have was a present and I don't know the password).

I did try to flash the BIOS by upgrading it. I created a BIOS recovery USB drive, but it turns out that BIOS will not start the update wizard since there might be some issue with CMOS. The procedure for resetting CMOS on this HP is not working at all (it's ignored and the laptop just boots up regularly).

Is there any way I can reset the BIOS password from the terminal? I lost a few hours Googling but I couldn't find any solution. It seems that my only chance is to do it from the terminal or some tool (if it exists).

Edit: Laptop: HP Folio 9470m (I followed instructions for BIOS flash from HP support doc.) CPU on laptop is supporting virtualization:

[root@DESKTOP-GHPREJB ivan]# lscpu
Architecture:        x86_64
CPU op-mode(s):      32-bit, 64-bit
Byte Order:          Little Endian
CPU(s):              4
On-line CPU(s) list: 0-3
Thread(s) per core:  2
Core(s) per socket:  2
Socket(s):           1
NUMA node(s):        1
Vendor ID:           GenuineIntel
CPU family:          6
Model:               58
Model name:          Intel(R) Core(TM) i5-3427U CPU @ 1.80GHz
Stepping:            9
CPU MHz:             941.480
CPU max MHz:         2800.0000
CPU min MHz:         800.0000
BogoMIPS:            4589.71
Virtualization:      VT-x


[root@DESKTOP-GHPREJB ivan]# egrep -q 'vmx|svm' /proc/cpuinfo && echo yes || echo no

Edit 2:

For future search results, this can help as this is the official reply I got from HP support on BIOS password reset request:

HP is committed to the security and privacy of its customers. HP has changed the policy regarding the BIOS Password Reset Service and will no longer provide this option to our customers. This change allows HP to protect customer’s data, BIOS configuration, and device settings, ensuring best in class security for HP products. Allowing access into the BIOS provides the potential opportunity for a rogue user to remove current security settings and change other device settings that could make the PC’s data vulnerable. For this reason, we are no longer able to reset the BIOS password for any reason. • The BIOS password feature on the HP PC was created for the users to provide an option to secure their PC at a hardware level, and it is the responsibility of the user to manage their password. If the BIOS password is forgotten, HP no longer provides a service to reset or remove the BIOS password. • If a unit has a BIOS password and is being sent in for repair, customer should remove the BIOS admin password and Power on password before the service is initiated. • If the unit has the password and the customer is unwilling/unable to provide the password, HP may not be able to complete the repair work. Then the option is that customer can replace the board at his/her own cost as this is not covered under warranty.

  • Please provide the model of the laptop. Commented Oct 6, 2020 at 16:38
  • Laptop: HP Folio 9470m (I followed instructions for BIOS flash from HP support doc.) I edited the original post with this info. Commented Oct 6, 2020 at 19:21
  • It would be helpful to have a link to the exact steps you followed... were they anything like this: ifixit.com/Wiki/… ? Commented Oct 6, 2020 at 19:30
  • I tried steps from this link and it didn't work. Before I tried 2 times steps under section "Recover the BIOS using a USB recovery drive" on this page: support.hp.com/us-en/document/c02693833 I just found this reply: eehelp.com/question/… I'm not sure this is legit but since nothing is working, it might be the case. Commented Oct 6, 2020 at 19:54

1 Answer 1


Try removing and replacing the CMOS battery. You can find the location of that in the hardware service manual in the HP support page of your model.

  • I did try that two times. Both times more then 30 minutes battery was disconnected and on the boot BIOS reported that CMOS was reset but it still asked for a password. Bonkers! Commented Oct 6, 2020 at 19:20
  • @IvanBlazevic You could desolder the BIOS chip and get a new one If you know how to do it. It is easy to find on the motherboard if you look for a chip that says something like AMIBIOS. But it is almost impossible to do it and you risk destroying your motherboard Commented Oct 19, 2020 at 16:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .