1

I'm on Arch right now, but I had the same problem (although slightly less often) on openSUSE Tumbleweed.

Basically, whenever I enter or leave a breakout room in Zoom, and sometimes randomly while I'm sitting in a room that's not a breakout room, Zoom gets muted and I have to go to my sound settings to bring the volume back up. My job is being done over Zoom right now and I have to switch in and out of breakout rooms a lot, so it's getting really inconvenient.

I've tried looking around online, and from what I can tell, Zoom will periodically swap input sinks, and that's when it gets muted (when I run pacmd list-sink-inputs, the index of Zoom changes, at least), and I've seen fixes for if a particular input sink gets muted, but not if the same application keeps muting (or nearly muting) over changing input sinks.

Any advice or ideas on how to fix greatly appreciated.

Edit: I've dug a little deeper, and it looks like the configuration file for pulse audio that defines the default input sink volumes for different processes is being changed automatically when Zoom runs, I've tried changing back with pa_volume, but it keeps changing it back. I was hoping to try to set up a script to watch for changes in that file and change it back when need be, but I haven't actually been able to detect changes using inotifywait so I'm stumped again.

3

1 Answer 1

1

I finally found the solution: open the Zoom Audio Settings tab and set the microphone input to Same as System. This allows Zoom to choose the correct microphone (I have two, one analog and one in the webcam) and the correct input sink.

After doing that last week (been in over 30 meetings since), we have not had a single problem! The microphone just works between different meetings and when the host switches in and out of breakout rooms.

I turned off auto adjust the volume and set it at a fixed volume; which also never changes from meeting to meeting.

Solved! :-)


One caveat: Zoom has to be completely closed between meetings, even the Zoom icon on the right of the taskbar. Right-click on it and select Exit. If this is not done, the microphone will not work when you connect to a meeting again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.