I searched a lot about this and ran through all the solution but non of them helped.

My laptop GPU is NVIDIA gt 540m so I tried to install nvidia-legacy-390xx-driver throughout this tutorial by using the official nvidia.com package and again, ran into a "Black screen with blinking underscore" after booting.

By the way Ctrl + Alt + F1 does work but didn't help...

OS: Debian 10

1 Answer 1


Your card has Nvidia Optimus optimisation and the regular configuration breaks Xorg on your system so you'll have to look at:


to see the best configuration to work around it. I went with "Using NVIDIA GPU as the primary GPU" and it seems to have fixed it. I also put the BusID "PCI:XX:XX:X" from the GPU in the /etc/X11/xorg.conf file under "Section 'Device'". You can get the BusID from from lspci. Hope this helps.

  • Yes, when I installed ubuntu on my system I noticed that It has set up all of the drivers (including the GPU) by itself. It was managed by disabling one of the GPU (either Intel or NVIDIA) with nvidia-prime. But anyways I managed it less than a few days posting this question.
    – Daniel
    Nov 30, 2020 at 21:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .