2

The question itself may not be very explanatory. Let me try and clarify it a bit. I'm running Pop!_OS 20.04 LTS on a PC. I'm also using a pair of Wireless USB headphones (Razer Nari) with two outputs.

What I am trying to achieve is to have STEREO output for my headphones. There are 2 outputs (one for 'gaming' and one for 'chat'. The 'gaming' one is stereo (at least on Windows) and the 'chat' one is mono (again, at least on Windows).

My issue is that I can't set pulseaudio to use stereo for my headphones' analog output (the gaming one).

In Sound Settings, I have "Analog Output - Razer Nari" and "Multichannel Output - Razer Nari". Each of them is tied to a mode on my headphones (note the game and chat icons in this photo). They both work when I switch to them from Sound settings but they are both MONO.

  • When switching to Analog Output, I see in pavucontrol that for Razer Nari, the Profile changes to Mono Output + Mono Input. (photo here)
  • When switching to Multichannel Output, I see in pavucontrol that for Razer Nari, the Profile changes to Multichannel Output + Mono Input. (photo here)

Either way, the sound coming out is mono, as well as it's confirmed when pressing the test button in Sound Settings (screenshot for multichannel / screenshot for analog output).

What I've tried so far:

  • switching USB ports;
  • resettings pulse settings with sudo dpkg-reconfigure pulse;
  • uninstalling pulseEffects;
  • resetting pulseEffects with sudo dpkg-reconfigure pulseeffects;
  • removing all user configurations of pulse and pulseeffects from ~/.config/pulse and ~/.config/pulseeffects

How can I force PulseEffects to use what I want or manually set my headphones to what channel(s) I want?

2

I found this on Github, a set of pulseaudio profiles which might make it work.

However, whilst stereo output was relatively easy to achieve for me, the mic didn't work for me at first

(loopback with the nari hardware wheel works, muting via nari / audiomixer but audiolevels always stay at 0, mint 19.3@5.0.0-32-generic, pulseaudio 11.1)

Turned out that somehow my other usb-soundcard interfered with it, detatching it before booting solved the problem but not during runtime. Weirdly, this seemed to also affect my VMware Setup (low level driver handover, Ubuntu20, pulseaudio 13.99 also not working- not Windows VM however)

further troubleshooting links:

2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.