9

I have installed tree on my ubuntu box, when i connect to it from Putty and I launch tree i get this :

$ tree
âââ html.vim -> xml.vim
âââ js.vim -> xml.vim
âââ xml.vim

instead of this :

$ tree --charset=ANSII
|-- html.vim -> xml.vim
|-- js.vim -> xml.vim
`-- xml.vim

I also get this problem when e.g. I list my packages from npm (package manager from nodejs)

$ npm list
/home/monkey/scripts/chatter
ââ⏠express@3.0.6
â âââ buffer-crc32@0.1.1
â âââ commander@0.6.1
â ââ⏠connect@2.7.2
â â âââ bytes@0.1.0

How can I change that (either from Putty or linux box) ?

  • 4
    Change the character translation in PuTTY to UTF-8. – zxcdw Jan 14 '13 at 19:56
17

Change the character translation in PuTTY to UTF-8.

0

Putty Menu > Change Settings... > Category : Window > Translation > Remote Character Set = UTF-8

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.