I have configured ELK on a single VM ( Centos 7 / 10Gig / 4 CPU) along with filebeat and auditbeat as POC and encountered the below error while trying to use the ingest manager.


I followed the security setup as suggested in this link, the elasticsearch wont come up after many attempts of troubleshooting and i need some help to fix it.

The logs suggest the below errors


HTTPS is required in order to use the API key service; please enable HTTPS using the [xpack.security.http.ssl.enabled] setting or disable the API key service using the [xpack.security.authc.api_key.enabled] setting

The elasticsearch config is below:

# Block initial recovery after a full cluster restart until N nodes are started:
#gateway.recover_after_nodes: 3
# For more information, consult the gateway module documentation.
# ---------------------------------- Various -----------------------------------
# Require explicit names when deleting indices:
bootstrap.memory_lock: true
#action.destructive_requires_name: true
xpack.license.self_generated.type: basic
xpack.monitoring.collection.enabled: true
xpack.security.enabled: true
xpack.security.authc.realms.file.users.order: 0
xpack.security.transport.ssl.enabled: true
xpack.security.authc.api_key.enabled: true
xpack.security.http.ssl.enabled: true
xpack.security.transport.ssl.enabled: true

xpack.security.enabled: true
xpack.security.transport.ssl.enabled: true
xpack.security.transport.ssl.keystore.path: /etc/elasticsearch/certs/ca.p12
xpack.security.transport.ssl.truststore.path: /etc/elasticsearch/certs/ca.p12
xpack.security.http.ssl.enabled: true
xpack.security.http.ssl.keystore.path: /etc/elasticsearch/certs/ca.p12
xpack.security.http.ssl.truststore.path: /etc/elasticsearch/certs/ca.p12

The Kibana config is below:

# Set the interval in milliseconds to sample system and process performance
# metrics. Minimum is 100ms. Defaults to 5000.
#ops.interval: 5000
# Specifies locale to be used for all localizable strings, dates and number formats.
# Supported languages are the following: English - en , by default , Chinese - zh-CN .
#i18n.locale: "en"
xpack.ingestManager.enabled: true
xpack.ingestManager.fleet.tlsCheckDisabled: true
xpack.security.enabled: true
xpack.encryptedSavedObjects.encryptionKey: "8ru3HMCHCLJfcWdKz2rtHQUX43krs5t9deb"
elasticsearch.username: "kibana_system"
elasticsearch.password: "welcome"
xpack.security.encryptionKey: "something_at_least_32_characters"
xpack.security.session.idleTimeout: "10m"
xpack.security.session.lifespan: "8h"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.