0

I neweblie linux user. I have installed kubuntu on my laptopn. Every time I see grub console at the startup. Console does not exit by timeout. I must to input "exit". How to disable grub console on startup?

0

In order to adjust grub 2 's behaviour, you can edit this configuration file /etc/default/grub and commit your changes using this command : sudo update-grub.

The GRUB documentation is here : http://www.gnu.org/software/grub/manual/grub/grub.html

Beware !
Before disabling the grub menu and console at boot, you need to ensure that your system can boot automatically on your preferred system ! If you have installed linux over (after) windows as a dual boot, you can adjust the default boot option in /etc/default/grub thru the key GRUB_DEFAULT (the default is GRUB_DEFAULT=0 then you can set GRUB_DEFAULT=1 )
and commit your changes by sudo update-grub.

When you are sure that your system is able to boot automatically, you can decide to remove the menu and/or the console or change their behaviours.

In order to shorten the menu's display duration you can adjust this option : GRUB_TIMEOUT=10
and commit your changes by sudo update-grub.

In order to hide the menu you need to change this option : GRUB_TIMEOUT_STYLE=menu
by : GRUB_TIMEOUT_STYLE=hidden

In order to remove the console you need to comment this line : GRUB_TERMINAL=console
by inserting # at the beginning of the line : #GRUB_TERMINAL=console

PS :
If you have 2 systems and still need to choose your boot, consider also the usage of GRUB_DEFAULT=saved and GRUB_SAVEDEFAULT=true
If you want to see the linux kernel messages when it boots (instead of the splash screen logo) you can switch the option GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to GRUB_CMDLINE_LINUX_DEFAULT="".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.