2

I am running GNOME 3.30.2 in Debian 10.6 with a dual monitor setup, and have some trouble with the workspaces. If I open a window in the area corresponding to my primary display on e.g. workspace 1, then this window appears only in workspace 1. However, if I place the window in the area corresponding to my secondary display, then that window appears on all four workspaces. Is this intended behaviour? Is there anyway I can change it so that a window, whether in the area corresponding to the primary or the secondary display, appears in one workspace, and one workspace only?

0
1

The author of the question found the following solution:

I found a solution in Karl Wilbur's answer over here: Switching workspaces on primary display only. One can change these settings using the tool gnome-tweaks.

The relevant part from Karl Wilbur's answer tells:

Config

  • select Workspaces from the left-hand list (at the bottom)
  • under "Display Handling", select
    • "Workspaces on primary display only" (for all other displays as "static")
    • "Workspaces span displays" (for all displays as a single, shared workspace)

Ref: https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1767564/comments/6

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.