0

There is a rabbitmq running on docker on my ubuntu aws server, which I connect to from my local pc app. After setting up https domain on nginx, it broke up (I am not sure if it the reason).

I tried to connect via telnet ip port which shows Connection closed by foreign host. Docker logs after above command:

2020-10-02 17:20:57.873 [info] <0.546.0> Resetting node maintenance status
2020-10-02 17:31:23.071 [info] <0.1670.0> accepting AMQP connection <0.1670.0> (84.54.87.17:58935 -> private_ip:5672)
2020-10-02 17:31:23.071 [error] <0.1670.0> closing AMQP connection <0.1670.0> (84.54.87.17:58935 -> private_ip:5672):
{handshake_timeout,handshake}

Interestingly, the same error occurs when I connect to rabbit_management plugin via telnet. But, i am able to access rabbit_management from browser.

Aws bounding rules and ufw ports are open

When run my app (python and aio_pika lib for rabbitmq client) following error occurs:

Could not get addresses to use: [Errno -2] Name or service not known (http)

How to fix this?

P.S. I use elastic ip to connect to rabbit, not domain name. But it should work in any case.

1 Answer 1

0

The problem was regarding the protocol. In my case as I blocked out incoming http requests, the http://ip was invalid request url, which should be changed to ip without http protocol.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .