1

I've gotten myself into a real pickle. My libc6 install seems to be broken, which has broken aptitude. I think I accidentally upgraded libc6 from buster-backports and maybe messed things up when I tried to downgrade.

When I run apt update I get the following error:

/usr/bin/perl: error while loading shared libraries lib crypt.so.1: cannot open shared object file: No such file or directory.

if I run apt-cache policy libc6 it returns the following:

Installed: 2.31-3
Candidate: 2.31-3 
Version Table:
**** 2.31-3 100
    100 /var/lib/dpkg/status
   2.28-10 500
    500 http://ftp.us.debian ... etc

EDIT: logs included below:

/var/log/apt/history.log

Start-Date: 2020-10-02  08:35:30
Commandline: apt install libc6=2.28-10 -V
Requested-By: mike (1000)
Downgrade: libc6:amd64 (2.31-3, 2.28-10)
Remove: liblapack3:amd64 (3.8.0-2), libumfpack5:amd64 (1:5.4.0+dfsg-1), libc6-dbg:amd64 (2.31-3), task-english:amd64 (3.53), libgegl-0.4-0:amd64 (0.4.12-2), xsane:amd64 (0.999-6+b1), task-ssh-server:amd64 (3.53), locales:amd64 (2.31-3), libcrypt1:amd64 (1:4.4.17-1), gimp:amd64 (2.10.8-2), libc-bin:amd64 (2.31-3), libgfortran5:amd64 (10.2.0-6), openssh-server:amd64 (1:8.3p1-1), libgimp2.0:amd64 (2.10.8-2), libcholmod3:amd64 (1:5.4.0+dfsg-1), libblas3:amd64 (3.8.0-2)
Error: Sub-process /usr/bin/dpkg returned an error code (2)
End-Date: 2020-10-02  08:35:33

Start-Date: 2020-10-02  08:36:55
Commandline: apt install libc6=2.28-10 -V
Requested-By: mike (1000)
Downgrade: libc6:amd64 (2.31-3, 2.28-10)
Remove: libcrypt1:amd64 (1:4.4.17-1)
Error: Sub-process /usr/bin/dpkg returned an error code (2)
End-Date: 2020-10-02  08:36:55

Start-Date: 2020-10-02  08:46:44
Commandline: apt remove ufw
Requested-By: mike (1000)
Remove: ufw:amd64 (0.36-1)
Error: Sub-process /usr/bin/dpkg returned an error code (2)
End-Date: 2020-10-02  08:46:44

Start-Date: 2020-10-02  08:47:29
Commandline: apt autoremove
Requested-By: mike (1000)
Remove: libraw19:amd64 (0.19.2-2), libgegl-common:amd64 (0.4.12-2), libccolamd2:amd64 (1:5.4.0+dfsg-1), gimp-data:amd64 (2.10.8-2), openssh-sftp-server:amd64 (1:8.3p1-1), libsuitesparseconfig5:amd64 (1:5.4.0+dfsg-1), libamd2:amd64 (1:5.4.0+dfsg-1), libgexiv2-2:amd64 (0.10.9-1), libmypaint-1.3-0:amd64 (1.3.0-2.1), libmetis5:amd64 (5.1.0.dfsg-5+b2), libbabl-0.1-0:amd64 (0.1.62-1), libcolamd2:amd64 (1:5.4.0+dfsg-1), libsdl1.2debian:amd64 (1.2.15+dfsg2-4), linux-image-4.19.0-8-amd64:amd64 (4.19.98-1+deb10u1), libcamd2:amd64 (1:5.4.0+dfsg-1), xsane-common:amd64 (0.999-6), libexiv2-14:amd64 (0.25-4+deb10u1), libmng1:amd64 (1.0.10+dfsg-3.1+b5), libmypaint-common:amd64 (1.3.0-2.1)
Error: Sub-process /usr/bin/dpkg returned an error code (2)
End-Date: 2020-10-02  08:47:29

Start-Date: 2020-10-02  08:52:38
Commandline: apt remove ufw
Remove: ufw:amd64 (0.36-1)
Error: Sub-process /usr/bin/dpkg returned an error code (2)
End-Date: 2020-10-02  08:52:38

Start-Date: 2020-10-02  08:56:38
Commandline: apt remove ufw
Remove: ufw:amd64 (0.36-1)
Error: Sub-process /usr/bin/dpkg returned an error code (2)
End-Date: 2020-10-02  08:56:38

Start-Date: 2020-10-02  09:03:48
Commandline: apt remove ufw
Remove: ufw:amd64 (0.36-1)
End-Date: 2020-10-02  09:03:50

Start-Date: 2020-10-02  09:03:55
Commandline: apt install ufw
Install: ufw:amd64 (0.36-1)
End-Date: 2020-10-02  09:03:58

Start-Date: 2020-10-02  09:10:37
Commandline: apt-get install libc6=2.28-10
Downgrade: libc6:amd64 (2.31-3, 2.28-10)
Remove: libcrypt1:amd64 (1:4.4.17-1)
Error: Sub-process /usr/bin/dpkg returned an error code (1)
End-Date: 2020-10-02  09:10:38

/var/log/apt/term.log

Log started: 2020-10-02  08:35:30
(Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 180914 files and directories currently installed.)
Removing gimp (2.10.8-2) ...
Removing xsane (0.999-6+b1) ...
Removing libgimp2.0 (2.10.8-2) ...
Removing libgegl-0.4-0:amd64 (0.4.12-2) ...
Removing libumfpack5:amd64 (1:5.4.0+dfsg-1) ...
Removing libcholmod3:amd64 (1:5.4.0+dfsg-1) ...
Removing liblapack3:amd64 (3.8.0-2) ...
Removing libblas3:amd64 (3.8.0-2) ...
Removing task-english (3.53) ...
Removing locales (2.31-3) ...
[1mdpkg:[0m [1;33mwarning:[0m overriding problem because --force enabled:
[1mdpkg:[0m [1;33mwarning:[0m this is an essential package; it should not be removed
Removing libc-bin (2.31-3) ...
Removing libc6-dbg:amd64 (2.31-3) ...
Removing task-ssh-server (3.53) ...
Removing openssh-server (1:8.3p1-1) ...
Removing libgfortran5:amd64 (10.2.0-6) ...
[1mdpkg:[0m [1;33mwarning:[0m 'ldconfig' not found in PATH or not executable
[1mdpkg:[0m [1;31merror:[0m 1 expected program not found in PATH or not executable
Note: root's PATH should usually contain /usr/local/sbin, /usr/sbin and /sbin
Log ended: 2020-10-02  08:35:33

Log started: 2020-10-02  08:36:55
[1mdpkg:[0m [1;33mwarning:[0m 'ldconfig' not found in PATH or not executable
[1mdpkg:[0m [1;31merror:[0m 1 expected program not found in PATH or not executable
Note: root's PATH should usually contain /usr/local/sbin, /usr/sbin and /sbin
Log ended: 2020-10-02  08:36:55

Log started: 2020-10-02  08:46:44
[1mdpkg:[0m [1;33mwarning:[0m 'ldconfig' not found in PATH or not executable
[1mdpkg:[0m [1;31merror:[0m 1 expected program not found in PATH or not executable
Note: root's PATH should usually contain /usr/local/sbin, /usr/sbin and /sbin
Log ended: 2020-10-02  08:46:44

Log started: 2020-10-02  08:47:29
[1mdpkg:[0m [1;33mwarning:[0m 'ldconfig' not found in PATH or not executable
[1mdpkg:[0m [1;31merror:[0m 1 expected program not found in PATH or not executable
Note: root's PATH should usually contain /usr/local/sbin, /usr/sbin and /sbin
Log ended: 2020-10-02  08:47:29

Log started: 2020-10-02  08:52:38
[1mdpkg:[0m [1;33mwarning:[0m 'ldconfig' not found in PATH or not executable
[1mdpkg:[0m [1;31merror:[0m 1 expected program not found in PATH or not executable
Note: root's PATH should usually contain /usr/local/sbin, /usr/sbin and /sbin
Log ended: 2020-10-02  08:52:38

Log started: 2020-10-02  08:56:38
[1mdpkg:[0m [1;33mwarning:[0m 'ldconfig' not found in PATH or not executable
[1mdpkg:[0m [1;31merror:[0m 1 expected program not found in PATH or not executable
Note: root's PATH should usually contain /usr/local/sbin, /usr/sbin and /sbin
Log ended: 2020-10-02  08:56:38

Log started: 2020-10-02  09:03:48
(Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 179298 files and directories currently installed.)
Removing ufw (0.36-1) ...
Skip stopping firewall: ufw (not enabled)
Processing triggers for mime-support (3.62) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for man-db (2.8.5-2) ...
Processing triggers for desktop-file-utils (0.23-4) ...
Log ended: 2020-10-02  09:03:50

Log started: 2020-10-02  09:03:55
Selecting previously unselected package ufw.
(Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 179207 files and directories currently installed.)
Preparing to unpack .../archives/ufw_0.36-1_all.deb ...
Unpacking ufw (0.36-1) ...
Setting up ufw (0.36-1) ...
Can't exec "locale": No such file or directory at /usr/share/perl5/Debconf/Encoding.pm line 16.
Use of uninitialized value $Debconf::Encoding::charmap in scalar chomp at /usr/share/perl5/Debconf/Encoding.pm line 17.
Processing triggers for man-db (2.8.5-2) ...
Processing triggers for rsyslog (8.1901.0-1) ...
Processing triggers for systemd (241-7~deb10u4) ...
Log ended: 2020-10-02  09:03:58

Log started: 2020-10-02  09:10:37
dpkg: libcrypt1:amd64: dependency problems, but removing anyway as you requested:
 libc6:amd64 depends on libcrypt1.

(Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 179298 files and directories currently installed.)
Removing libcrypt1:amd64 (1:4.4.17-1) ...
dpkg: warning: downgrading libc6:amd64 from 2.31-3 to 2.28-10
(Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 179294 files and directories currently installed.)
Preparing to unpack .../libc6_2.28-10_amd64.deb ...
/usr/bin/perl: error while loading shared libraries: libcrypt.so.1: cannot open shared object file: No such file or directory
dpkg: error processing archive /var/cache/apt/archives/libc6_2.28-10_amd64.deb (--unpack):
 new libc6:amd64 package pre-installation script subprocess returned error exit status 127
Errors were encountered while processing:
 /var/cache/apt/archives/libc6_2.28-10_amd64.deb
Log ended: 2020-10-02  09:10:38

/var/log/dpkg/log:

2020-10-02 08:35:30 startup packages remove
2020-10-02 08:35:30 status installed gimp:amd64 2.10.8-2
2020-10-02 08:35:31 remove gimp:amd64 2.10.8-2 <none>
2020-10-02 08:35:31 status half-configured gimp:amd64 2.10.8-2
2020-10-02 08:35:31 status half-installed gimp:amd64 2.10.8-2
2020-10-02 08:35:31 status triggers-pending man-db:amd64 2.8.5-2
2020-10-02 08:35:31 status triggers-pending desktop-file-utils:amd64 0.23-4
2020-10-02 08:35:31 status triggers-pending mime-support:all 3.62
2020-10-02 08:35:31 status config-files gimp:amd64 2.10.8-2
2020-10-02 08:35:31 status not-installed gimp:amd64 <none>
2020-10-02 08:35:31 status installed xsane:amd64 0.999-6+b1
2020-10-02 08:35:31 remove xsane:amd64 0.999-6+b1 <none>
2020-10-02 08:35:31 status half-configured xsane:amd64 0.999-6+b1
2020-10-02 08:35:31 status half-installed xsane:amd64 0.999-6+b1
2020-10-02 08:35:31 status triggers-pending hicolor-icon-theme:all 0.17-2
2020-10-02 08:35:31 status config-files xsane:amd64 0.999-6+b1
2020-10-02 08:35:31 status not-installed xsane:amd64 <none>
2020-10-02 08:35:31 status installed libgimp2.0:amd64 2.10.8-2
2020-10-02 08:35:31 remove libgimp2.0:amd64 2.10.8-2 <none>
2020-10-02 08:35:31 status triggers-pending libc-bin:amd64 2.31-3
2020-10-02 08:35:31 status half-configured libgimp2.0:amd64 2.10.8-2
2020-10-02 08:35:31 status half-installed libgimp2.0:amd64 2.10.8-2
2020-10-02 08:35:31 status config-files libgimp2.0:amd64 2.10.8-2
2020-10-02 08:35:31 status not-installed libgimp2.0:amd64 <none>
2020-10-02 08:35:31 status installed libgegl-0.4-0:amd64 0.4.12-2
2020-10-02 08:35:31 remove libgegl-0.4-0:amd64 0.4.12-2 <none>
2020-10-02 08:35:31 status half-configured libgegl-0.4-0:amd64 0.4.12-2
2020-10-02 08:35:31 status half-installed libgegl-0.4-0:amd64 0.4.12-2
2020-10-02 08:35:31 status config-files libgegl-0.4-0:amd64 0.4.12-2
2020-10-02 08:35:31 status not-installed libgegl-0.4-0:amd64 <none>
2020-10-02 08:35:31 status installed libumfpack5:amd64 1:5.4.0+dfsg-1
2020-10-02 08:35:31 remove libumfpack5:amd64 1:5.4.0+dfsg-1 <none>
2020-10-02 08:35:31 status half-configured libumfpack5:amd64 1:5.4.0+dfsg-1
2020-10-02 08:35:31 status half-installed libumfpack5:amd64 1:5.4.0+dfsg-1
2020-10-02 08:35:31 status config-files libumfpack5:amd64 1:5.4.0+dfsg-1
2020-10-02 08:35:31 status not-installed libumfpack5:amd64 <none>
2020-10-02 08:35:31 status installed libcholmod3:amd64 1:5.4.0+dfsg-1
2020-10-02 08:35:31 remove libcholmod3:amd64 1:5.4.0+dfsg-1 <none>
2020-10-02 08:35:31 status half-configured libcholmod3:amd64 1:5.4.0+dfsg-1
2020-10-02 08:35:31 status half-installed libcholmod3:amd64 1:5.4.0+dfsg-1
2020-10-02 08:35:31 status config-files libcholmod3:amd64 1:5.4.0+dfsg-1
2020-10-02 08:35:31 status not-installed libcholmod3:amd64 <none>
2020-10-02 08:35:31 status installed liblapack3:amd64 3.8.0-2
2020-10-02 08:35:31 remove liblapack3:amd64 3.8.0-2 <none>
2020-10-02 08:35:31 status half-configured liblapack3:amd64 3.8.0-2
2020-10-02 08:35:31 status half-installed liblapack3:amd64 3.8.0-2
2020-10-02 08:35:31 status config-files liblapack3:amd64 3.8.0-2
2020-10-02 08:35:31 status not-installed liblapack3:amd64 <none>
2020-10-02 08:35:31 status installed libblas3:amd64 3.8.0-2
2020-10-02 08:35:31 remove libblas3:amd64 3.8.0-2 <none>
2020-10-02 08:35:31 status half-configured libblas3:amd64 3.8.0-2
2020-10-02 08:35:31 status half-installed libblas3:amd64 3.8.0-2
2020-10-02 08:35:32 status config-files libblas3:amd64 3.8.0-2
2020-10-02 08:35:32 status not-installed libblas3:amd64 <none>
2020-10-02 08:35:32 status installed task-english:all 3.53
2020-10-02 08:35:32 remove task-english:all 3.53 <none>
2020-10-02 08:35:32 status half-configured task-english:all 3.53
2020-10-02 08:35:32 status half-installed task-english:all 3.53
2020-10-02 08:35:32 status config-files task-english:all 3.53
2020-10-02 08:35:32 status not-installed task-english:all <none>
2020-10-02 08:35:32 status installed locales:all 2.31-3
2020-10-02 08:35:32 remove locales:all 2.31-3 <none>
2020-10-02 08:35:32 status half-configured locales:all 2.31-3
2020-10-02 08:35:32 status half-installed locales:all 2.31-3
2020-10-02 08:35:32 status config-files locales:all 2.31-3
2020-10-02 08:35:32 remove libc-bin:amd64 2.31-3 <none>
2020-10-02 08:35:32 status half-configured libc-bin:amd64 2.31-3
2020-10-02 08:35:32 status half-installed libc-bin:amd64 2.31-3
2020-10-02 08:35:32 status config-files libc-bin:amd64 2.31-3
2020-10-02 08:35:32 status installed libc6-dbg:amd64 2.31-3
2020-10-02 08:35:32 remove libc6-dbg:amd64 2.31-3 <none>
2020-10-02 08:35:32 status half-configured libc6-dbg:amd64 2.31-3
2020-10-02 08:35:32 status half-installed libc6-dbg:amd64 2.31-3
2020-10-02 08:35:32 status config-files libc6-dbg:amd64 2.31-3
2020-10-02 08:35:32 status not-installed libc6-dbg:amd64 <none>
2020-10-02 08:35:32 status installed task-ssh-server:all 3.53
2020-10-02 08:35:32 remove task-ssh-server:all 3.53 <none>
2020-10-02 08:35:32 status half-configured task-ssh-server:all 3.53
2020-10-02 08:35:32 status half-installed task-ssh-server:all 3.53
2020-10-02 08:35:32 status config-files task-ssh-server:all 3.53
2020-10-02 08:35:32 status not-installed task-ssh-server:all <none>
2020-10-02 08:35:32 status installed openssh-server:amd64 1:8.3p1-1
2020-10-02 08:35:32 remove openssh-server:amd64 1:8.3p1-1 <none>
2020-10-02 08:35:32 status half-configured openssh-server:amd64 1:8.3p1-1
2020-10-02 08:35:32 status half-installed openssh-server:amd64 1:8.3p1-1
2020-10-02 08:35:33 status config-files openssh-server:amd64 1:8.3p1-1
2020-10-02 08:35:33 status installed libgfortran5:amd64 10.2.0-6
2020-10-02 08:35:33 remove libgfortran5:amd64 10.2.0-6 <none>
2020-10-02 08:35:33 status half-configured libgfortran5:amd64 10.2.0-6
2020-10-02 08:35:33 status half-installed libgfortran5:amd64 10.2.0-6
2020-10-02 08:35:33 status config-files libgfortran5:amd64 10.2.0-6
2020-10-02 08:35:33 status not-installed libgfortran5:amd64 <none>
2020-10-02 09:03:48 startup packages remove
2020-10-02 09:03:48 status installed ufw:all 0.36-1
2020-10-02 09:03:49 remove ufw:all 0.36-1 <none>
2020-10-02 09:03:49 status half-configured ufw:all 0.36-1
2020-10-02 09:03:49 status half-installed ufw:all 0.36-1
2020-10-02 09:03:49 status config-files ufw:all 0.36-1
2020-10-02 09:03:49 startup packages configure
2020-10-02 09:03:49 trigproc mime-support:all 3.62 <none>
2020-10-02 09:03:49 status half-configured mime-support:all 3.62
2020-10-02 09:03:49 status installed mime-support:all 3.62
2020-10-02 09:03:49 trigproc hicolor-icon-theme:all 0.17-2 <none>
2020-10-02 09:03:49 status half-configured hicolor-icon-theme:all 0.17-2
2020-10-02 09:03:50 status installed hicolor-icon-theme:all 0.17-2
2020-10-02 09:03:50 trigproc man-db:amd64 2.8.5-2 <none>
2020-10-02 09:03:50 status half-configured man-db:amd64 2.8.5-2
2020-10-02 09:03:50 status installed man-db:amd64 2.8.5-2
2020-10-02 09:03:50 trigproc desktop-file-utils:amd64 0.23-4 <none>
2020-10-02 09:03:50 status half-configured desktop-file-utils:amd64 0.23-4
2020-10-02 09:03:50 status installed desktop-file-utils:amd64 0.23-4
2020-10-02 09:03:55 startup archives unpack
2020-10-02 09:03:55 install ufw:all 0.36-1 0.36-1
2020-10-02 09:03:55 status half-installed ufw:all 0.36-1
2020-10-02 09:03:55 status triggers-pending systemd:amd64 241-7~deb10u4
2020-10-02 09:03:55 status triggers-pending rsyslog:amd64 8.1901.0-1
2020-10-02 09:03:55 status triggers-pending man-db:amd64 2.8.5-2
2020-10-02 09:03:55 status unpacked ufw:all 0.36-1
2020-10-02 09:03:55 startup packages configure
2020-10-02 09:03:55 configure ufw:all 0.36-1 <none>
2020-10-02 09:03:55 status unpacked ufw:all 0.36-1
2020-10-02 09:03:55 status half-configured ufw:all 0.36-1
2020-10-02 09:03:57 status installed ufw:all 0.36-1
2020-10-02 09:03:57 trigproc man-db:amd64 2.8.5-2 <none>
2020-10-02 09:03:57 status half-configured man-db:amd64 2.8.5-2
2020-10-02 09:03:57 status installed man-db:amd64 2.8.5-2
2020-10-02 09:03:57 trigproc rsyslog:amd64 8.1901.0-1 <none>
2020-10-02 09:03:57 status half-configured rsyslog:amd64 8.1901.0-1
2020-10-02 09:03:57 status installed rsyslog:amd64 8.1901.0-1
2020-10-02 09:03:57 trigproc systemd:amd64 241-7~deb10u4 <none>
2020-10-02 09:03:57 status half-configured systemd:amd64 241-7~deb10u4
2020-10-02 09:03:58 status installed systemd:amd64 241-7~deb10u4
2020-10-02 09:10:37 startup packages remove
2020-10-02 09:10:37 status installed libcrypt1:amd64 1:4.4.17-1
2020-10-02 09:10:37 remove libcrypt1:amd64 1:4.4.17-1 <none>
2020-10-02 09:10:37 status half-configured libcrypt1:amd64 1:4.4.17-1
2020-10-02 09:10:37 status half-installed libcrypt1:amd64 1:4.4.17-1
2020-10-02 09:10:37 status config-files libcrypt1:amd64 1:4.4.17-1
2020-10-02 09:10:37 status not-installed libcrypt1:amd64 <none>
2020-10-02 09:10:37 startup archives unpack
2020-10-02 09:10:37 upgrade libc6:amd64 2.31-3 2.28-10
2020-10-02 09:10:37 status half-configured libc6:amd64 2.31-3
2020-10-02 09:10:37 status unpacked libc6:amd64 2.31-3
2020-10-02 09:10:37 status half-installed libc6:amd64 2.31-3
2020-10-02 09:10:37 status unpacked libc6:amd64 2.31-3
2020-10-02 09:10:37 status installed libc6:amd64 2.31-3
2020-10-02 09:13:38 startup archives install
2020-10-02 09:13:38 upgrade libc6:amd64 2.31-3 2.28-10
2020-10-02 09:13:38 status half-configured libc6:amd64 2.31-3
2020-10-02 09:13:38 status unpacked libc6:amd64 2.31-3
2020-10-02 09:13:38 status half-installed libc6:amd64 2.31-3
2020-10-02 09:13:38 status unpacked libc6:amd64 2.31-3
2020-10-02 09:13:38 status installed libc6:amd64 2.31-3
2020-10-02 09:39:38 startup packages configure
2020-10-02 09:48:43 startup archives install
2020-10-02 09:48:44 upgrade libc6:amd64 2.31-3 2.28-10
2020-10-02 09:48:44 status half-configured libc6:amd64 2.31-3
2020-10-02 09:48:44 status unpacked libc6:amd64 2.31-3
2020-10-02 09:48:44 status half-installed libc6:amd64 2.31-3
2020-10-02 09:48:44 status unpacked libc6:amd64 2.31-3
2020-10-02 09:48:44 status installed libc6:amd64 2.31-3
2020-10-02 14:37:59 startup archives install
2020-10-02 14:39:16 startup archives install
2020-10-02 14:39:16 upgrade libc6:amd64 2.31-3 2.28-10
2020-10-02 14:39:16 status half-configured libc6:amd64 2.31-3
2020-10-02 14:39:16 status unpacked libc6:amd64 2.31-3
2020-10-02 14:39:16 status half-installed libc6:amd64 2.31-3
2020-10-02 14:39:16 status unpacked libc6:amd64 2.31-3
2020-10-02 14:39:16 status installed libc6:amd64 2.31-3

To make things more fun I rebooted the machine and am now locked out, so whatever we do I'll have to do it with chroot from a live USB.

8
  • Wasn't from buster-backports (libc6 is never available in backports, else that'd like changing distribution), but from testing/sid. Depending on what else you (didn't) upgrade, you might be able to use dpkg to reinstall the correct version. But if many things were upgraded, you might instead break those many things even more. – A.B Oct 2 '20 at 17:34
  • Can you help me give that a try? – Mike Oct 2 '20 at 17:43
  • I can't really because I don't have important informations from your question: what was upgraded. Giving an answer as is would likely not work or make your issues worse. This information can probably be retrieved from contents of /var/log/apt/history.log and /var/log/apt/term.log . You should provide what was the command done and its result. You might have to limit those logs to avoid getting a too big question. Doesn't mean I'll do an answer, but it would help answerers. – A.B Oct 2 '20 at 17:47
  • If that was done using dpkg instead, there's no log but you'll know what was explictly upgraded – A.B Oct 2 '20 at 17:52
  • 1
    dpkg logs to /var/log/dpkg.log by default, so anything done with dpkg should be visible there. – Stephen Kitt Oct 2 '20 at 18:00
0

Ended up having to do a new install of Debian. In my case the server only ran UFW, Samba, Avahi and CUPS. Using the Debian live USB I copied /home for my admin user and /etc to a tarball using sudo tar -cvpf, and installed a new instance of Debian 10. I extracted the tarballs to a temp folder. For each item I ran apt install, copied the relevant /etc from the tarball temp to /etc/*, then ran sudo systemctl start SERVICE and sudo systemctl enable SERVICE.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.