I know, that you can add applications with right click -> Add to favorites.

But I want to add / remove the favorites via script.

I was trying to use the solution from this question but

When executing following command:

gsettings get org.gnome.shell favorite-apps

I receive following error:

No such schema »org.gnome.shell«

When searching all gsettings for 'favorite' there wasn't anything that fits.

The only thing is com.linuxmint.mintmenu.plugins.applications but that's empty. (My favorites are definetely not empty)

gsettings list-recursively | grep 'favorite'

com.linuxmint.mintmenu applet-icons ['linuxmint-logo', 'linuxmint-logo-badge', 'linuxmint-logo-badge-symbolic', 'linuxmint-logo-filled-badge', 'linuxmint-logo-filled-leaf-badge', 'linuxmint-logo-filled-leaf', 'linuxmint-logo-filled-ring', 'linuxmint-logo-leaf-badge', 'linuxmint-logo-leaf-badge-symbolic', 'linuxmint-logo-leaf', 'linuxmint-logo-leaf-symbolic', 'linuxmint-logo-neon', 'linuxmint-logo-ring', 'linuxmint-logo-ring-symbolic', 'linuxmint-logo-simple', 'linuxmint-logo-simple-symbolic', 'mate-symbolic', 'emblem-favorite-symbolic', 'user-bookmarks-symbolic', 'start-here-symbolic']
com.linuxmint.mintmenu start-with-favorites false
org.x.warpinator.preferences favorites @as []
com.linuxmint.mintmenu.plugins.applications favorite-apps-list @as []

I couldn't find a solution where my favorites are saved or can be changed.

Does anyone know a solution for my problem?


I found the solution on my own. The solution was quiet simple..

I executed the command as root, that's the reason why the favorite-apps-list was empty, after executing as my user everything worked as expected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.