2

I have just installed solarized theme for vim from https://github.com/altercation/vim-colors-solarized

But the problem for me is that the background stays black and I have the variable names in really dark blue color. Like so :

enter image description here

Does anyone know how to change that to ? (namely: where it is stored in the theme ?)

2
  • 2
    I think you must have either skipped an installation step or overlooked a prerequisite, such as a 256-color terminal. That's not Solarized. Not even close. (Speaking as one who has lived with this theme every weekday for about a year now.) Commented Jan 14, 2013 at 12:53
  • @WarrenYoung the problem was that I did not put let g:solarized_termcolors=256 before colorscheme solarized
    – Patryk
    Commented Jan 14, 2013 at 13:22

2 Answers 2

2

/usr/share/vim/vim73/colors/ contains themes for vim 7.3, but you can copy your scheme to ~/.vim/colors/ and edit it.

2

You're not really using solarized.

It looks like you have the 16-color solarize theme selected in vim but your color pallet is still the default. You have two options:

  1. Use the 256-color emulated pallet (see the README on how to do this).
  2. Set your terminal colors to solarized colors.

If you're using gnome-terminal there's a color pallet setting utility bundled with Solarized. Execute it then restart your terminal.

If you're using something motif based (xterm, aterm, rxvt, etc) you'll need to set this in your ~/.Xdefaults file (an example of which can be found here.

If you're using Mac OS X Terminal.app you either need to set the colors by hand (using the included Solarized pallet helps) or use the 256-color emulated pallet.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .