1

Some new behaviour in Konsole has prevented both screen and tmux from scrolling the window. I mostly use screen and when using the mouse wheel to scroll it would spin through the command line history. Annoying, but you could still use the mouse wheel in the scroll bar. In the last few days this has stopped working. A screen session will not scroll at all, the scroll bar is solid and won't work. I switched to tmux, but that has the same problem. There is a mouse pass through mode for tmux which is half ok but it is clunky and cut and paste doesn't work. A basic xterm doesn't show the problem. I can't think of what has changed that could have done this.

2 Answers 2

0

the scroll bar is solid and won't work

You have switched to the alternate screen buffer. Konsole is one of several terminal emulators that makes the alternate screen buffer magically different to the main one. It magically isn't scrollable and does not have a scrollback buffer.

Switch back with tput:

tput te
(the terminfo name for this capability being rmcup) or with my portable setterm tool:

setterm --altbuffer off
or by simply outputting the control sequence (RM of DEC Private Mode 1047) longhand with printf.

Further reading

  • Jonathan de Boyne Pollard (2018). setterm. nosh Guide. Softwares.
2
  • No, it is not this. I'm well aware of the alternative screen buffer, and ways to switch it off. This is something different that isn't in the many previous answers I have searched through. Oct 1, 2020 at 18:12
  • 1
    If your only tool is a hammer then every problem looks like a nail.
    – user232326
    Oct 14, 2020 at 6:01
0

I solved the problem by modifying the local TERM environment variable. I had tried multiple variations of this when logged in to the remote session via screen but none of the standard VT100 / xterm emulations made any difference.

The problem seems to revolve around screen taking the konsole session terminal definition and generating another, on the fly, TERMCAP. The solution is to change the TERM environment variable: "TERM=vt100 ssh -t user@host screen -RR" for the session. The TERMCAP that gets produced has the correct scrollbar behaviour.

Not sure it makes much sense, but it fixed it for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .